Bug 861899 - [RFE] make possible re-entering BZ credentials if bug processing fails due to bad BZ username/passwd
[RFE] make possible re-entering BZ credentials if bug processing fails due to...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: abrt (Show other bugs)
18
Unspecified Unspecified
medium Severity unspecified
: ---
: ---
Assigned To: Jakub Filak
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-01 05:41 EDT by Martin Kyral
Modified: 2016-11-30 19:42 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-11 20:16:02 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot (639.97 KB, image/png)
2012-10-01 05:41 EDT, Martin Kyral
no flags Details

  None (edit)
Description Martin Kyral 2012-10-01 05:41:17 EDT
Created attachment 619709 [details]
Screenshot

Description of problem:
If processing a bug with bad (mistyped) BZ username and/or password, processing of the bug fails, giving the user no obvious way to re-enter the credentials and process the bug again.

The only way to do so, is to open abrt-gui / gnome-abrt manually, fix the BZ settings and then retry to report the issue.


Version-Release number of selected component (if applicable):
abrt-2.0.13-1.fc18

How reproducible:
Always


Steps to Reproduce:
1. configure wrong BZ username or password
2. try to report a bug
  
Actual results:
Processing fails, the failure message is:
--- Running report_Bugzilla ---
Logging into Bugzilla at https://bugzilla.redhat.com
fatal: RPC failed at server.  The username or password you entered is not valid.
(exited with 1)

and the only button in the reporting window is "Close"

Expected results:
After the BZ submit fails due to bad username/password, a dialog for fixing the BZ settings is displayed and the window contains a "Try again" button.


Additional info:
Comment 1 D. Hugh Redelmeier 2012-11-16 21:35:23 EST
I agree.  A minimal work-around would put some hints in the failure message.

Thanks, Martin.  I will try to rerun abrt using the technique you outlined.

Hmm. That doesn't seem to work.  There is no gnome-abrt on my F17.  There is an abrt-gui but I don't see any way to tell it that I want to change my credentials.
Comment 2 D. Hugh Redelmeier 2012-11-17 14:35:49 EST
Thanks to help from Sergio <sergiocmailbox-userlist@yahoo.com.br> on the Fedora Users List, I was able to change the credentials.

"Edit": "Preferences" gets you an "Even Configuration" window.

In that window, you need to select "Bugzilla: report to Bugzilla bug
tracker" and click on "Configure Event".

Then you get a window where you can adjust credentials.
Comment 3 Jakub Filak 2012-12-06 09:52:08 EST
Fixed in git

commit 0eda6c9b976f22d0468cf9376592b13c1b297614
Author: Jakub Filak <jfilak@redhat.com>
Date:   Wed Dec 5 17:30:56 2012 +0100

    ask for BZ login/BZ password if not provided by conf
    
    Signed-off-by: Jakub Filak <jfilak@redhat.com>


commit 20813f2d6b0f2d2600572665f156ca7ae0650672
Author: Jakub Filak <jfilak@redhat.com>
Date:   Wed Dec 5 18:01:30 2012 +0100

    ask for BZ login/BZ pwd if Login attempt failed
    
    - closes rhbz#861899
    
    Signed-off-by: Jakub Filak <jfilak@redhat.com>
Comment 4 Fedora Update System 2012-12-20 03:55:00 EST
abrt-2.0.20-1.fc18,btparser-0.24-1.fc18,libreport-2.0.20-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/abrt-2.0.20-1.fc18,btparser-0.24-1.fc18,libreport-2.0.20-1.fc18
Comment 5 Fedora Update System 2012-12-20 04:45:24 EST
abrt-2.0.20-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/abrt-2.0.20-1.fc17
Comment 6 Fedora Update System 2012-12-20 20:29:24 EST
Package abrt-2.0.20-1.fc18, btparser-0.24-1.fc18, libreport-2.0.20-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing abrt-2.0.20-1.fc18 btparser-0.24-1.fc18 libreport-2.0.20-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-20725/abrt-2.0.20-1.fc18,btparser-0.24-1.fc18,libreport-2.0.20-1.fc18
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2013-01-11 20:16:04 EST
abrt-2.0.20-1.fc18, btparser-0.24-1.fc18, libreport-2.0.20-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2013-02-25 21:38:07 EST
abrt-2.0.20-1.fc17, btparser-0.24-1.fc17, libreport-2.0.20-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.