Bug 8619 - No license
No license
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: rdate (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Crutcher Dunnavant
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-01-19 12:18 EST by Donnie Barnes
Modified: 2013-05-29 20:19 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-04 14:01:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Donnie Barnes 2000-01-19 12:18:36 EST
This package contains *no* license.  It is my understanding that it makes
it unshippable for us since the copyright is owned by the original author.
I guess someone needs to attempt to contact the author (an email address is
in the source package, but it's dated 1994 so this isn't likely) or we're
going to have to remove this package.  *grumble*
Comment 1 Elliot Lee 2000-02-04 14:01:59 EST
Wrote a new rdate. Problem solved.
Comment 2 David Woodhouse 2007-12-22 05:05:19 EST
Er, Christos Zoulas is a member of the NetBSD core team. Do we actually have any
reason to believe his code wasn't BSD-licensed, and did we actually make any
attempt to contact him?
Comment 3 Adam Williamson 2013-05-29 20:19:34 EDT
Let's do another necro!

the 'openrdate' at http://sourceforge.net/projects/openrdate/ lists this in its COPYING file:

rdate.c, rfc868time.c:
/*
 * Copyright (c) 1994 Christos Zoulas
 * All rights reserved.
 *
 * With slight modifications by David Snyder, copyright (c) 2005
 *
 * Redistribution and use in source and binary forms, with or without
 * modification, are permitted provided that the following conditions
 * are met:
 * 1. Redistributions of source code must retain the above copyright
 *    notice, this list of conditions and the following disclaimer.
 * 2. Redistributions in binary form must reproduce the above copyright
 *    notice, this list of conditions and the following disclaimer in the
 *    documentation and/or other materials provided with the distribution.
 * 3. All advertising materials mentioning features or use of this software
 *    must display the following acknowledgement:
 *      This product includes software developed by Christos Zoulas.
 * 4. The name of the author may not be used to endorse or promote products
 *    derived from this software without specific prior written permission.
 *
 * THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR
 * IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES
 * OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.
 * IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT,
 * INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT
 * NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
 * DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
 * THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
 * (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF
 * THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
 */

So obviously someone did contact Christos, and the original rdate implementation indeed was under BSD-with-advertising.

Honza Horak is packaging openrdate to replace our 'rdate' (which we've been carrying ever since comment #1...), I'm reviewing it, and that will bring an end to this saga :)

Note You need to log in before you can comment on or make changes to this bug.