This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 861914 - Python based plasmoids fail to run, since update to 4.9.2
Python based plasmoids fail to run, since update to 4.9.2
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kde-workspace (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lukáš Tinkl
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-01 06:31 EDT by Martin Airs
Modified: 2015-07-13 04:11 EDT (History)
8 users (show)

See Also:
Fixed In Version: kde-workspace-4.9.2-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-01 08:42:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Airs 2012-10-01 06:31:47 EDT
Description of problem:
Since updating to KDE 4.9.2 I cannot run any python based plasmoids

Version-Release number of selected component (if applicable):
kde 4.9.2, fedora 17 x86_64, plasma-scriptengine-python-4.9.2-1.fc17.x86_64

How reproducible:
always

Steps to Reproduce:
1.plasmoidviewer <python based plasmoid>
2.
3.
  
Actual results:

used veromix as an example as its python based, others fail too

[martin@desktop ircplasmoid]$ plasmoidviewer veromix-plasmoid
Traceback (most recent call last):
  File "/usr/share/kde4/apps/plasma_scriptengine_python/pyappletscript.py", line 59, in init
    self.module = __import__(self.pluginName+'.'+relpath)
  File "/usr/share/kde4/apps/plasma_scriptengine_python/plasma_importer.py", line 107, in load_module
    exec (code in mod.__dict__)
TypeError: exec: arg 1 must be a string, file, or code object

Expected results:
to run.

Additional info:

Have spoken to a guy in #plasma on freenode, and he has fixed it upstream, he says its fixed in, plasma-scriptengine-python revision: 92c79ebd767fd90eafa1e3865bfbbddcfa695c08

Just filed this bug to track it and hopefully get a fix in quickly
Thank you
Comment 1 Lukáš Tinkl 2012-10-01 06:56:08 EDT
$ python --version
Comment 2 Lukáš Tinkl 2012-10-01 06:57:01 EDT
I see a related "fix" in the 4.9 branch that's supposed to make it work with Python 3, perhaps it breaks with older versions...

http://commits.kde.org/kde-workspace/48464db91116bc75263ea42d364f358e2019175c
Comment 3 Lukáš Tinkl 2012-10-01 06:58:19 EDT
Ah yes, and the fix is here :)

http://commits.kde.org/kde-workspace/92c79ebd767fd90eafa1e3865bfbbddcfa695c08
Comment 4 Rex Dieter 2012-10-01 08:21:21 EDT
yay, thanks.  Lukáš included the patch in our kde-workspace-4.9.2-2 builds


looks like upstream has intentions to respin a new kde-workspace-4.9.2 with that fix included, we'll see.
Comment 5 Lukáš Tinkl 2012-10-01 08:42:21 EDT
Fixed in kde-workspace-4.9.2-2.fc19

Note You need to log in before you can comment on or make changes to this bug.