Bug 861919 - 'gluster volume status' does not show brick information if server is down
'gluster volume status' does not show brick information if server is down
Status: CLOSED DUPLICATE of bug 852147
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterfs (Show other bugs)
2.0
x86_64 Linux
high Severity medium
: ---
: ---
Assigned To: Kaushal
amainkar
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-01 07:11 EDT by Rachana Patel
Modified: 2015-04-20 07:56 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-29 03:46:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rachana Patel 2012-10-01 07:11:47 EDT
Description of problem:
'gluster volume status' does not show brick information if server is down


Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. Create a  volume having 3 or more sub-volumes on multiple server and start that volume.

[root@Rhs3 ~]# gluster volume info test
 
Volume Name: test
Type: Distribute
Volume ID: 0e785456-78f5-42e0-84fa-b375a89b813c
Status: Started
Number of Bricks: 3
Transport-type: tcp
Bricks:
Brick1: XX1:/home/t1
Brick2: XX2:/home/t1
Brick3: XX3:/home/t1


2. Bring the server down having one or more sub-volumes
[root@Rhs3 ~]# poweroff

3. Check the gluster volume status and info.

[root@Rhs3 ~]# gluster volume info test
 
Volume Name: test
Type: Distribute
Volume ID: 0e785456-78f5-42e0-84fa-b375a89b813c
Status: Started
Number of Bricks: 3
Transport-type: tcp
Bricks:
Brick1: XX1:/home/t1
Brick2: XX2:/home/t1
Brick3: XX3:/home/t1


[root@Rhs1 ~]# gluster volume status test
Status of volume: test
Gluster process						Port	Online	Pid
------------------------------------------------------------------------------
Brick XX1:/home/t1					24009	Y	14939
Brick XX2:/home/t1					24211	Y	12569
NFS Server on localhost					38467	Y	14952
NFS Server on 10.70.35.85				38467	Y	12581

  
Actual results:
It is not showing Brick 3 info which is on down server

Expected results:
Even though server is down, it should show it in 'gluster volume status <vol-name>' result

Additional info:
Comment 2 Amar Tumballi 2012-11-29 03:46:46 EST

*** This bug has been marked as a duplicate of bug 852147 ***

Note You need to log in before you can comment on or make changes to this bug.