Bug 861994 - munin-node-2.0.6-2.el5.noarch installs munin-asyncd incorrectly
munin-node-2.0.6-2.el5.noarch installs munin-asyncd incorrectly
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: distribution (Show other bugs)
5.8
All Linux
unspecified Severity medium
: rc
: ---
Assigned To: RHEL Product and Program Management
nobody nobody
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-01 10:32 EDT by arth
Modified: 2017-02-20 09:21 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-02 09:04:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
art-rh: needinfo-


Attachments (Terms of Use)

  None (edit)
Description arth 2012-10-01 10:32:52 EDT
Description of problem:

munin-node installs /etc/init.d/munin-asyncd incorrectly
This script contains:
DAEMON=@@LIBDIR@@/${ASYNC_BIN}
PIDFILE=@@STATEDIR@@/${ASYNC_BIN}.pid

The autoconfig variables @@LIBDIR@@ and @@STATEDIR@@ have not been resolved, and as a result, the script can never start the daemon.  This can not possibly have been tested.

Version-Release number of selected component (if applicable):

munin-node-2.0.6-2.el5.noarch
munin-async-2.0.6-2.el5.noarch

How reproducible:

yum install munin-node
/etc/init.d/munin-async start

Additional info:

Another question is why /etc/init.d/munin-asyncd is in the munin-node package, and not in the munin-async package.
Comment 1 Daniel Forsberg 2013-02-04 03:38:55 EST
this have ben changed in 2.0.9 but is still wrong...

munin-asyncd is not installed in /usr/sbin it is installed under /usr/share/munin/
Comment 2 Daniel Black 2014-01-31 19:45:37 EST
Also munin-async requires munin-node to be started before it otherwise it will just stop. So in the init script:

# Required-Start: $local_fs $remote_fs $network munin-node
# Required-Stop: $local_fs $remote_fs $network
Comment 3 RHEL Product and Program Management 2014-03-07 07:41:19 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 4 RHEL Product and Program Management 2014-06-02 09:04:31 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Note You need to log in before you can comment on or make changes to this bug.