Bug 862016 - Add [redhat] section to rhui-tools.conf file
Add [redhat] section to rhui-tools.conf file
Status: CLOSED ERRATA
Product: Red Hat Update Infrastructure for Cloud Providers
Classification: Red Hat
Component: RHUA (Show other bugs)
2.1
All Linux
high Severity medium
: ---
: 2.1.1
Assigned To: James Slagle
mkovacik
:
: 861904 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-01 11:35 EDT by Calvin Locklear
Modified: 2013-02-27 11:59 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Proxy settings weren't parsed in the rhui-tools configuration file and caused content synchronization to fail. This fix adds in [redhat] section to rhui-tools.conf so that the proxy setting are parsed without errors.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-27 11:59:42 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Calvin Locklear 2012-10-01 11:35:36 EDT
Description of problem:
Http proxy settings aren't honored in the rhui-tools.conf file, unless they are added to the [redhat] section.  The [redhat] itself needs to be added to the rhui-tools.conf file. 

Version-Release number of selected component (if applicable):
RHUI 2.1

How reproducible:
Build out a new RHUI2.1, there is no [redhat] section in the rhui-tools.conf file.

Steps to Reproduce:
1. Build a new rhua.
2. Check the rhui-tools.conf file.
3.
  
Actual results:
There is no [redhat] section in the rhui-tools.conf file.

Expected results:
There should be a [redhat] section in the rhui-tools.conf file.

Additional info:
Comment 2 James Slagle 2012-10-01 13:33:49 EDT
*** Bug 861904 has been marked as a duplicate of this bug. ***
Comment 6 James Slagle 2012-11-01 07:50:35 EDT
This is aligned against our RHUI 2.1.1 release.  There is no firm schedule yet,
but we're thinking it will be Q1 of 2013 when it's released.
Comment 8 James Slagle 2012-11-28 16:32:12 EST
commit ceeb860c247a6b171e48da960c933205cbb1537b
Comment 9 James Slagle 2012-11-28 16:33:20 EST
QA: make sure when you set a proxy server, username, and password in the answers file that those settings get propogated to /etc/rhui/rhui-tools.conf and the proxy is used successfully when rhui-manager communicated with the CDN, such as when you add redhat repos.
Comment 12 Vitaly Kuznetsov 2013-02-04 09:03:30 EST
[root@rhua ~]# rpm -q rh-rhui-tools
rh-rhui-tools-2.1.15-1.el6_3.noarch

[root@rhua ~]# grep -B1 proxy /etc/rhui/answers
[rhua]
proxy_server_host: proxy.example.com
proxy_server_port: 3128
proxy_server_username: rhua
proxy_server_password: password

[root@rhua ~]# grep 'proxy' /etc/rhui/rhui-tools.conf | grep -v "^#"
proxy_url = http://proxy.example.com
proxy_port = 3128
proxy_user = rhua
proxy_pass = password

[root@rhua ~]# grep 'proxy' /etc/pulp/pulp.conf | grep -v "^#"
proxy_url = http://proxy.example.com
proxy_port = 3128
proxy_user = rhua
proxy_pass = password
Comment 14 errata-xmlrpc 2013-02-27 11:59:42 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0571.html

Note You need to log in before you can comment on or make changes to this bug.