Bug 862017 - quorum is not restored when a server is removed from the cluster
quorum is not restored when a server is removed from the cluster
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterd (Show other bugs)
2.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Pranith Kumar K
Sudhir D
:
Depends On:
Blocks: 840122 874018
  Show dependency treegraph
 
Reported: 2012-10-01 11:36 EDT by Sachidananda Urs
Modified: 2013-09-23 18:43 EDT (History)
4 users (show)

See Also:
Fixed In Version: glusterfs-3.3.0.5rhs-36
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 18:39:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sachidananda Urs 2012-10-01 11:36:05 EDT
Description of problem:

Consider a scenario where the quorum ratio is set to 100%. And one of the server goes down... and quorum is lost and the bricks are killed.

Now we peer detach that server with force. Quorum should be restored, but it doesn't.
Comment 2 Amar Tumballi 2012-10-08 03:09:26 EDT
pranith already has the patch submitted for this..
Comment 3 Sachidananda Urs 2012-11-07 04:36:36 EST
Verified with newer release. When the disconnected peer is deprobed, quorum is restored.
Comment 4 Scott Haines 2013-09-23 18:39:15 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html
Comment 5 Scott Haines 2013-09-23 18:43:42 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.