Bug 862031 - [abrt] ibus-1.4.99.20120914-2.fc17: panel_switch_engine: Process /usr/libexec/ibus-ui-gtk3 was killed by signal 6 (SIGABRT)
[abrt] ibus-1.4.99.20120914-2.fc17: panel_switch_engine: Process /usr/libexec...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
abrt_hash:6d8a757ef0c4bf260d6e39481e8...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-01 12:50 EDT by Yogesh
Modified: 2013-03-28 03:01 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-03 21:44:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: core_backtrace (1.79 KB, text/plain)
2012-10-01 12:50 EDT, Yogesh
no flags Details
File: environ (688 bytes, text/plain)
2012-10-01 12:50 EDT, Yogesh
no flags Details
File: backtrace (17.52 KB, text/plain)
2012-10-01 12:50 EDT, Yogesh
no flags Details
File: limits (1.29 KB, text/plain)
2012-10-01 12:50 EDT, Yogesh
no flags Details
File: cgroup (129 bytes, text/plain)
2012-10-01 12:51 EDT, Yogesh
no flags Details
File: maps (31.72 KB, text/plain)
2012-10-01 12:51 EDT, Yogesh
no flags Details
File: dso_list (6.76 KB, text/plain)
2012-10-01 12:51 EDT, Yogesh
no flags Details
File: var_log_messages (628 bytes, text/plain)
2012-10-01 12:51 EDT, Yogesh
no flags Details
File: open_fds (668 bytes, text/plain)
2012-10-01 12:51 EDT, Yogesh
no flags Details

  None (edit)
Description Yogesh 2012-10-01 12:50:44 EDT
Description of problem:
Got this problem whenever I switch on or restart the laptop. Having this problem since last two updates.

Version-Release number of selected component:
ibus-1.4.99.20120914-2.fc17

Additional info:
libreport version: 2.0.14
abrt_version:   2.0.13
backtrace_rating: 4
cmdline:        /usr/libexec/ibus-ui-gtk3
crash_function: panel_switch_engine
kernel:         3.5.4-2.fc17.x86_64

truncated backtrace:
:Thread no. 1 (7 frames)
: #4 panel_switch_engine at panel.c:2730
: #5 panel_update_engines at panel.c:3236
: #6 panel_set_config at panel.c:1358
: #7 emit_signal_instance_in_idle_cb at gdbusconnection.c:3665
: #12 gtk_main at gtkmain.c:1161
: #13 application_run at application.c:218
: #14 application_main at application.c:342
Comment 1 Yogesh 2012-10-01 12:50:50 EDT
Created attachment 619877 [details]
File: core_backtrace
Comment 2 Yogesh 2012-10-01 12:50:52 EDT
Created attachment 619878 [details]
File: environ
Comment 3 Yogesh 2012-10-01 12:50:56 EDT
Created attachment 619879 [details]
File: backtrace
Comment 4 Yogesh 2012-10-01 12:50:59 EDT
Created attachment 619880 [details]
File: limits
Comment 5 Yogesh 2012-10-01 12:51:01 EDT
Created attachment 619881 [details]
File: cgroup
Comment 6 Yogesh 2012-10-01 12:51:06 EDT
Created attachment 619882 [details]
File: maps
Comment 7 Yogesh 2012-10-01 12:51:08 EDT
Created attachment 619883 [details]
File: dso_list
Comment 8 Yogesh 2012-10-01 12:51:11 EDT
Created attachment 619884 [details]
File: var_log_messages
Comment 9 Yogesh 2012-10-01 12:51:13 EDT
Created attachment 619885 [details]
File: open_fds
Comment 10 fujiwara 2012-10-01 21:47:43 EDT
(In reply to comment #3)
> Created attachment 619879 [details]
> File: backtrace

> #3  0x000000318ba68ed4 in g_assertion_message_expr (domain=domain@entry=0x41b2bd "IBUS", file=file@entry=0x41ca10 "panel.c", line=line@entry=2730, func=func@entry=0x41cf30 "panel_switch_engine", expr=expr@entry=0x41cbcc "_tmp4_") at gtestutils.c:1872
>         s = <optimized out>
> #4  0x0000000000413a4f in panel_switch_engine (self=0x23c2480, i=<optimized out>, force=<optimized out>) at panel.c:2730
> #5  0x0000000000414209 in panel_update_engines (self=self@entry=0x23c2480, var_engines=var_engines@entry=0x7fbdbc1d5790, var_order=var_order@entry=0x7fbdbc1d6b90) at panel.c:3236
...
>         _tmp33__length1 = 1
...


I cannot reproduce your problem. It seems ibus_bus_get_engines_by_names(bus, ["xkb:us::eng"]) returns the null list in your stack.

Are you able to reproduce your problem with a new user account instead of the current user account?

You might not restart ibus or the dconf value /desktop/ibus/general/preload-engines might be wrong.

% dconf read /desktop/ibus/general/preload-engines
['xkb:us::eng', 'anthy',]
Comment 11 Yogesh 2012-10-02 03:12:13 EDT
Iḿ not facing the problem with a new user account. When I started ibus hangul preferences under new user, it showing error as 
<<IBus daemon is not running.
Hangul engine settings cannot be saved>>
Itś dconf value for preload-engines reads as []

I disabled ibus from gnome-session-properties in my current user account and now Iḿ not facing the problem.
Comment 12 fujiwara 2012-10-02 04:24:19 EDT
(In reply to comment #11)
> <<IBus daemon is not running.
> Hangul engine settings cannot be saved>>
> Itś dconf value for preload-engines reads as []

I'm asking if you see your problem with a new user account when ibus-daemon *is running*.
Comment 13 Yogesh 2012-10-03 13:32:31 EDT
I'm not facing the error with new user account. I think I messed up with my ibus settings. I reseted ibus by deleting config files from <<.config>> folder. Now I don't have the problem. 
Thanks
Comment 14 fujiwara 2012-10-03 21:44:33 EDT
(In reply to comment #13)
> I'm not facing the error with new user account. I think I messed up with my
> ibus settings. I reseted ibus by deleting config files from <<.config>>
> folder. Now I don't have the problem. 
> Thanks

OK, you might not have the write permission under .config/ibus due to changed user id.
I think your problem is not happened generally.
Please comment here if you notice the difference between the old .config and new one.
Comment 15 fujiwara 2012-10-03 21:53:55 EDT
(In reply to comment #14)
> (In reply to comment #13)
> > I'm not facing the error with new user account. I think I messed up with my
> > ibus settings. I reseted ibus by deleting config files from <<.config>>
> > folder. Now I don't have the problem. 
> > Thanks
> 
> OK, you might not have the write permission under .config/ibus due to
> changed user id.

Or your specific preference might caused your problem.
If you notice the difference of running 'dconf dump /' between the old .config/dconf/user and the new one, please comment here.
Comment 16 Bradley John Schaufenbuel 2013-03-22 12:44:04 EDT
I have installed Fedora 17 on two different laptops from two different manufacturers and I am getting this error every time each laptop boots up.  These are straight out of the box installs.  I have not altered the configuration of anything.  Something is not right with ibus.
Comment 17 Martin Gregorie 2013-03-24 15:31:50 EDT
I am also getting it immediately on login Fedora 17, Lenovo R61i

.config/ibus belongs to me and has user rwx permissions and no access at all for group or world.

The one file in .config/ibus - 2523deb844d38aebf8b8778900000010-unix-0
belongs to me. User has rw permissions while group and works are read only.
Comment 18 fujiwara 2013-03-26 03:17:43 EDT
(In reply to comment #16)
> I have installed Fedora 17 on two different laptops from two different
> manufacturers and I am getting this error every time each laptop boots up. 
> These are straight out of the box installs.  I have not altered the
> configuration of anything.  Something is not right with ibus.

Did you try with a new user account instead of the current user one?
If you don't see any problems with a new user account, probably the dconf value has no-existent engines and it would be good clean up your dconf data.

% dconf read /desktop/ibus/general/preload-engines
% dconf reset /desktop/ibus/general/preload-engines

% ibus-daemon --xim --replace --cache refresh &

(In reply to comment #17)
> I am also getting it immediately on login Fedora 17, Lenovo R61i
> 
> .config/ibus belongs to me and has user rwx permissions and no access at all
> for group or world.
> 
> The one file in .config/ibus - 2523deb844d38aebf8b8778900000010-unix-0
> belongs to me. User has rw permissions while group and works are read only.

That file is not used by dconf. It's a right permission.
dconf data is $HOME/.config/dconf/user
Comment 19 Bradley John Schaufenbuel 2013-03-26 09:56:23 EDT
I did try adding a new user account as suggested in previous posts, but it did not fix the problem.  Running the commands provided by fujiwara appears to have fixed the problem on both of my machines.  So thank you fujiwara for the solution!

The fact remains, however, that this was a problem for me with two fresh (unaltered) builds of Fedora.  I personally had never used ibus before and never messed with its configuration.  So unless we think it acceptable that everyone who builds a Fedora box should get have to troubleshoot ibus issues, it would be nice to figure out what the root cause of the problem was.
Comment 20 Martin Gregorie 2013-03-26 10:40:46 EDT
I tried the commands:

% dconf read /desktop/ibus/general/preload-engines
% dconf reset /desktop/ibus/general/preload-engines

% ibus-daemon --xim --replace --cache refresh &

as suggested by fujiwara but they didn't work for me. The first two ran to completion, but the 'ibus-daemon' command seemed to hang and when, some time later, I jogged out and in again the ibus crash happened again immediateld after the login completed.
Comment 21 Bradley John Schaufenbuel 2013-03-26 12:54:58 EDT
I spoke too soon.  ibus failed on the next reboot of both machines.  I give up.  I will just turn it off.
Comment 22 fujiwara 2013-03-26 20:54:54 EDT
(In reply to comment #20)

Did you install the latest ibus?
# yum install ibus

It would be good to see the verbose log after terminate ibus with right click on ibus icon and choosing "Quit":

% ibus-daemon --xim --verbose
Comment 23 Bradley John Schaufenbuel 2013-03-26 21:20:12 EDT
Yes.  I run "yum upgrade" pretty regularly and have been through at least a couple of updates of ibus that I can recall.  The problem persisted after each update.  I will capture a verbose log and post it soon.  Thanks.
Comment 24 Bradley John Schaufenbuel 2013-03-27 15:14:24 EDT
When I start ibus-daemon in verbose mode, I immediately see the following:

(ibus-ui-gtk3:9003): IBUS-WARNING **: ibus_bus_call_sync: org.freedesktop.IBus.GetGlobalEngine: GDBus.Error:org.freedesktop.DBus.Error.Failed: No global engine.

No error is thrown when I quit the application.
Comment 25 Bradley John Schaufenbuel 2013-03-27 15:21:31 EDT
I am running ibus version 1.5.1.
Comment 26 fujiwara 2013-03-28 03:01:25 EDT
(In reply to comment #24)
> (ibus-ui-gtk3:9003): IBUS-WARNING **: ibus_bus_call_sync:
> org.freedesktop.IBus.GetGlobalEngine:
> GDBus.Error:org.freedesktop.DBus.Error.Failed: No global engine.

The warning is an expected result and not a problem.

Do you talk about this bug?
I think abrt shows the following errors and ibus verbose mode shows the similar errors in this bug:

> (In reply to comment #3)
> Created attachment 619879 [details]
> File: backtrace
> #0  0x000000318be35925 in __GI_raise (sig=sig@entry=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
>         resultvar = 0
>         pid = 1354
>         selftid = 1354
> #1  0x000000318be370d8 in __GI_abort () at abort.c:91
>         save_stage = 2
>         act = {__sigaction_handler = {sa_handler = 0x2958be0, sa_sigaction = 0x2958be0}, sa_mask = {__val = {0, 212799189632, 212791780068, 5, 0, 212800138344, 6845471435946078691, 39408928, 212799189632, 72, 212791806229, 0, 0, 212803979072, 4294967295, 212803979040}}, sa_flags = 1, sa_restorer = 0}
>         sigs = {__val = {32, 0 <repeats 15 times>}}
> #2  0x000000318ba689b7 in g_assertion_message (domain=domain@entry=0x41b2bd "IBUS", file=file@entry=0x41ca10 "panel.c", line=line@entry=2730, func=func@entry=0x41cf30 "panel_switch_engine", message=<optimized out>) at gtestutils.c:1861
>         lstr = "2730\000\177\000\000\000D~\205\377\177\000\000\310\252\240\213\061\000\000\000\314\313A\000\000\000\000"
>         s = 0x2595520 ""
> #3  0x000000318ba68ed4 in g_assertion_message_expr (domain=domain@entry=0x41b2bd "IBUS", file=file@entry=0x41ca10 "panel.c", line=line@entry=2730, func=func@entry=0x41cf30 "panel_switch_engine", expr=expr@entry=0x41cbcc "_tmp4_") at gtestutils.c:1872
>         s = <optimized out>
> #4  0x0000000000413a4f in panel_switch_engine (self=0x23c2480, i=<optimized out>, force=<optimized out>) at panel.c:2730
>         _tmp0_ = <optimized out>
>         _tmp1_ = <optimized out>
>         _tmp4_ = <optimized out>
>         _tmp5_ = 0
>         _tmp6_ = <optimized out>
>         _tmp8_ = <optimized out>
>         _tmp9__length1 = <optimized out>
>         _tmp10_ = <optimized out>
>         engine = <optimized out>
>         _tmp14_ = <optimized out>
>         _tmp19_ = <optimized out>

Note You need to log in before you can comment on or make changes to this bug.