Bug 862060 - Pressing [Esc] to abort media check during ovirt-node installation ends in kernel panic
Pressing [Esc] to abort media check during ovirt-node installation ends in ke...
Status: CLOSED DUPLICATE of bug 839632
Product: oVirt
Classification: Community
Component: ovirt-node (Show other bugs)
unspecified
x86_64 Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Mike Burns
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-01 14:21 EDT by jirib
Modified: 2016-04-27 00:56 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-03 11:32:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jirib 2012-10-01 14:21:23 EDT
Description of problem:

During installation of ovirt-node (with ovirt-node-iso-2.5.1-1.0.fc17.iso mounted as IPMI media) there's media check showing [Esc] to abort. While pressing [Esc] the installation finishes in kernel panic. Same error if using VGA as console or serial (output below is from serial to get plain-text output).

Version-Release number of selected component (if applicable):

ovirt-node-iso-2.5.1-1.0.fc17.iso

How reproducible:

Always when pressing [Esc].

Steps to Reproduce:
1. Plug iso via IPMI.
2. Boot from iso.
3. Press [Esc] when there's written on the console you can abort media check.
  
Actual results:

=~=~=~=~=~=~=~=~=~=~=~= PuTTY log 2012.10.01 20:02:55 =~=~=~=~=~=~=~=~=~=~=~=
[    1.027698] ERST: Failed to get Error Log Address Range.
ÿudevd[165]: sender uid=-1, message ignored

Couldn't open /dev/ttyS0
[    4.139429] sd 6:0:0:0: [sdc] No Caching mode page present
[    4.144995] sd 6:0:0:0: [sdc] Assuming drive cache: write through
[    4.154199] sd 6:0:0:0: [sdc] No Caching mode page present
[    4.160004] sd 6:0:0:0: [sdc] Assuming drive cache: write through
[    4.170241] sd 6:0:0:0: [sdc] No Caching mode page present
[    4.176123] sd 6:0:0:0: [sdc] Assuming drive cache: write through
/dev/sr0:   d0ed67c95a7c0001e54e23d0a7d2ebe8
Fragment sums: 11ac34c3a2ea581cd5ac6c7aabe41da683f82c5be953ed31bff3c49e1971
Fragment count: 20
Press [Esc] to abort check.

Checking: 000.0%
Checking: 000.0%
Checking: 000.0%
Checking: 000.1%
Checking: 000.1%
Checking: 000.1%
Checking: 000.1%
Checking: 000.1%
Checking: 000.1%
Checking: 000.2%
Checking: 000.2%
Checking: 000.2%
Checking: 000.2%
Checking: 000.2%
Checking: 000.3%
Checking: 000.3%
Checking: 000.3%
Checking: 000.3%
Checking: 000.3%
Checking: 000.3%
Checking: 000.4%
Checking: 000.4%
Checking: 000.4%
Checking: 000.4%
Checking: 000.4%
Checking: 000.5%
Checking: 000.5%
Checking: 000.5%
Checking: 000.5%
Checking: 000.5%
Checking: 000.5%
Checking: 000.6%
Checking: 000.6%
Checking: 000.6%
Checking: 000.6%
Checking: 000.6%
Checking: 000.7%
Checking: 000.7%
Checking: 000.7%
Checking: 000.7%
Checking: 000.7%
Checking: 000.7%
Checking: 000.8%
Checking: 000.8%
Checking: 000.8%
Checking: 000.8%
Checking: 000.8%
Checking: 000.9%
Checking: 000.9%
Checking: 000.9%
Checking: 000.9%
Checking: 000.9%
Checking: 000.9%
Checking: 001.0%
Checking: 001.0%
Checking: 001.0%
Checking: 001.0%
Checking: 001.0%
Checking: 001.1%
Checking: 001.1%
Checking: 001.1%
Checking: 001.1%
Checking: 001.1%
Checking: 001.1%
Checking: 001.2%
Checking: 001.2%
Checking: 001.2%
Checking: 001.2%
Checking: 001.2%
Checking: 001.2%
Checking: 001.3%
Checking: 001.3%
Checking: 001.3%
Checking: 001.3%
Checking: 001.3%
Checking: 001.4%
Checking: 001.4%
Checking: 001.4%
Checking: 001.4%
Checking: 001.4%
Checking: 001.4%
Checking: 001.5%
Checking: 001.5%
Checking: 001.5%
Checking: 001.5%
Checking: 001.5%
Checking: 001.6%
Checking: 001.6%
Checking: 001.6%
Checking: 001.6%
Checking: 001.6%
Checking: 001.6%
Checking: 001.7%
Checking: 001.7%
Checking: 001.7%
Checking: 001.7%
Checking: 001.7%
Checking: 001.8%
Checking: 001.8%
Checking: 001.8%
Checking: 001.8%
Checking: 001.8%
Checking: 001.8%
Checking: 001.9%
Checking: 001.9%
Checking: 001.9%
Checking: 001.9%
Checking: 001.9%
Checking: 002.0%
Checking: 002.0%
Checking: 002.0%
Checking: 002.0%
Checking: 002.0%
Checking: 002.0%
Checking: 002.1%
Checking: 002.1%
Checking: 002.1%
Checking: 002.1%
Checking: 002.1%
Checking: 002.2%
Checking: 002.2%
Checking: 002.2%
Checking: 002.2%
Checking: 002.2%
Checking: 002.2%
Checking: 002.3%
Checking: 002.3%
Checking: 002.3%
Checking: 002.3%
Checking: 002.3%
Checking: 002.4%
Checking: 002.4%
Checking: 002.4%
Checking: 002.4%
Checking: 002.4%
Checking: 002.4%
Checking: 002.5%
Checking: 002.5%
Checking: 002.5%
Checking: 002.5%
Checking: 002.5%
Checking: 002.6%
Checking: 002.6%
Checking: 002.6%
Checking: 002.6%
Checking: 002.6%
Checking: 002.6%
Checking: 002.7%
Checking: 002.7%
Checking: 002.7%
Checking: 002.7%
Checking: 002.7%
Checking: 002.8%
Checking: 002.8%
Checking: 002.8%
Checking: 002.8%
Checking: 002.8%
Checking: 002.8%
Checking: 002.9%
Checking: 002.9%
Checking: 002.9%
Checking: 002.9%
Checking: 002.9%
Checking: 003.0%
Checking: 003.0%
Checking: 003.0%
Checking: 003.0%
Checking: 003.0%
Checking: 003.0%
Checking: 003.1%
Checking: 003.1%
Checking: 003.1%
Checking: 003.1%
Checking: 003.1%
Checking: 003.2%
Checking: 003.2%
Checking: 003.2%
Checking: 003.2%
Checking: 003.2%
Checking: 003.2%
Checking: 003.3%
Checking: 003.3%
Checking: 003.3%
Checking: 003.3%
Checking: 003.3%
Checking: 003.3%
Checking: 003.4%
Checking: 003.4%
Checking: 003.4%
Checking: 003.4%
Checking: 003.4%
Checking: 003.5%
Checking: 003.5%
Checking: 003.5%
Checking: 003.5%
Checking: 003.5%
Checking: 003.5%
Checking: 003.6%
Checking: 003.6%
Checking: 003.6%
Checking: 003.6%
Checking: 003.6%
Checking: 003.7%
Checking: 003.7%
Checking: 003.7%
Checking: 003.7%
Checking: 003.7%
Checking: 003.7%
Checking: 003.8%
Checking: 003.8%
Checking: 003.8%
Checking: 003.8%
Checking: 003.8%
Checking: 003.9%
Checking: 003.9%
Checking: 003.9%
Checking: 003.9%
Checking: 003.9%
Checking: 003.9%
Checking: 004.0%
Checking: 004.0%
Checking: 004.0%
Checking: 004.0%
Checking: 004.0%
Checking: 004.1%
Checking: 004.1%
Checking: 004.1%
Checking: 004.1%
Checking: 004.1%
Checking: 004.1%
Checking: 004.2%
Checking: 004.2%
Checking: 004.2%
Checking: 004.2%
Checking: 004.2%
Checking: 004.3%
Checking: 004.3%
Checking: 004.3%
Checking: 004.3%
Checking: 004.3%
Checking: 004.3%
Checking: 004.4%
Checking: 004.4%
Checking: 004.4%
Checking: 004.4%
Checking: 004.4%
Checking: 004.5%
Checking: 004.5%
Checking: 004.5%
Checking: 004.5%
Checking: 004.5%
Checking: 004.5%
Checking: 004.6%
Checking: 004.6%
Checking: 004.6%
Checking: 004.6%
Checking: 004.6%
Checking: 004.7%
Checking: 004.7%
Checking: 004.7%
Checking: 004.7%
Checking: 004.7%
Checking: 004.7%
Checking: 004.8%
Checking: 004.8%
Checking: 004.8%
Checking: 004.8%
Checking: 004.8%
Checking: 004.9%
Checking: 004.9%
Checking: 004.9%
Checking: 004.9%
Checking: 004.9%
Checking: 004.9%
Checking: 005.0%
Checking: 005.0%
Checking: 005.0%
Checking: 005.0%
Checking: 005.0%
Checking: 005.1%
Checking: 005.1%
Checking: 005.1%
Checking: 005.1%
Checking: 005.1%
Checking: 005.1%
Checking: 005.2%
Checking: 005.2%
Checking: 005.2%
Checking: 005.2%
Checking: 005.2%
Checking: 005.3%
Checking: 005.3%

The media chec[    7.040489] dracut: FATAL: CD check failed!
k is complete, t[    7.045986] dracut: Refusing to continue
he result is: UNKNOWN.

The media check was aborted.

dracut Warning: Unable to process initqueue
dracut Warning: dracut: FATAL: CD c[   27.081976] Kernel panic - not syncing: Attempted to kill init! exitcode=0x00000100
[   27.081976] 
heck failed!
dr[   27.092539] Pid: 1, comm: init Not tainted 3.5.0-2.fc17.x86_64 #1
acut Warning: dr[   27.100735] Call Trace:
acut: Refusing t[   27.104913]  [<ffffffff815fd9d7>] panic+0xba/0x1c9
o continue
drac[   27.111725]  [<ffffffff8105e35a>] do_exit+0x7fa/0x8c0
ut Warning: /dev[   27.118711]  [<ffffffff8106b4c7>] ? __set_task_blocked+0x37/0x80
/mapper/live-rw [   27.126812]  [<ffffffff8105e76f>] do_group_exit+0x3f/0xa0
[   27.134318]  [<ffffffff8105e7e7>] sys_exit_group+0x17/0x20
does not exist
[   27.140060]  [<ffffffff8160fc29>] system_call_fastpath+0x16/0x1b

dracut War

Expected results:

As installation informs user that he can press [Esc], it should work and not finish in kernel panic.

Additional info:
Comment 1 Mike Burns 2012-10-03 11:32:38 EDT

*** This bug has been marked as a duplicate of bug 839632 ***

Note You need to log in before you can comment on or make changes to this bug.