Bug 862068 - interacting with Pulp with a user with UTF8 characters in the name causes tracebacks
interacting with Pulp with a user with UTF8 characters in the name causes tra...
Status: CLOSED DUPLICATE of bug 835586
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
Unspecified Unspecified
unspecified Severity unspecified (vote)
: Unspecified
: --
Assigned To: Mike McCune
Og Maciel
: Triaged
Depends On: 862356
  Show dependency treegraph
Reported: 2012-10-01 14:53 EDT by Mike McCune
Modified: 2014-01-27 09:21 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2012-10-02 15:36:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Mike McCune 2012-10-01 14:53:16 EDT
If you create a user in Katello that has utf8 characters in the username and then attempt to interact with pulp with syncs, repo discovery or anything that requires delayed task processing you will see errors in Katello and Pulp.

How to reproduce (create a user, a repo and sync):

katello -u admin -p admin user create --username "Mané" --password redhat --email "mane@somecorp.com"
katello -u admin -p admin user assign_role --username "Mané" --role "Administrator"
katello -u Mané -p redhat org create --name Cuiabá --label Cuiaba
katello -u Mané -p redhat provider create --name test_prov --org Cuiabá
katello -u Mané -p redhat product create --name Cuiabá_prod --provider test_prov --org Cuiabá
katello -u Mané -p redhat repo create --name Cuiabá_repo --product Cuiabá_prod --org Cuiabá --product Cuiabá_prod
katello -u Mané -p redhat repo synchronize --name Cuiabá_prod_dummy_repos_zoo --org Cuiabá --product Cuiabá_prod

Error in pulp log:

2012-10-01 10:48:16,450 11917:140154905814784: pulp.server.webservices.controllers.repositories:INFO: repositories:1179 sync timeout passed : None
2012-10-01 10:48:16,500 11917:140155184740096: pulp:CRITICAL: queue:130 Exception in FIFO Queue Dispatch Thread
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/pulp/server/tasking/taskqueue/queue.py", line 124, in _dispatch
  File "/usr/lib/python2.6/site-packages/pulp/server/tasking/taskqueue/queue.py", line 314, in run
  File "/usr/lib/python2.6/site-packages/pulp/server/tasking/taskqueue/storage.py", line 232, in store_running
  File "/usr/lib/python2.6/site-packages/pulp/server/tasking/taskqueue/storage.py", line 223, in _snapshot_task
    snapshot = task.snapshot()
  File "/usr/lib/python2.6/site-packages/pulp/server/api/repo_sync_task.py", line 64, in snapshot
    snapshot = super(RepoSyncTask, self).snapshot()
  File "/usr/lib/python2.6/site-packages/pulp/server/tasking/task.py", line 314, in snapshot
    snapshot = model.TaskSnapshot(data)
  File "/usr/lib/python2.6/site-packages/pulp/server/db/model/persistence.py", line 45, in __init__
  File "/usr/lib/python2.6/site-packages/pulp/server/db/model/persistence.py", line 58, in _process_serialized_task
    return dict([(k, _process_value(v)) for k, v in serialized_task.items()])
  File "/usr/lib/python2.6/site-packages/pulp/server/db/model/persistence.py", line 55, in _process_value
    value = value.decode('utf-8')
  File "/usr/lib64/python2.6/encodings/utf_8.py", line 16, in decode
    return codecs.utf_8_decode(input, errors, True)
UnicodeDecodeError: 'utf8' codec can't decode byte 0xe9 in position 270: invalid continuation byte
Comment 1 Mike McCune 2012-10-02 13:37:39 EDT
pulp bug:

Comment 2 Mike McCune 2012-10-02 15:36:58 EDT

*** This bug has been marked as a duplicate of bug 835586 ***

Note You need to log in before you can comment on or make changes to this bug.