Bug 862146 - [RFE] bkr client could do with a --version option
[RFE] bkr client could do with a --version option
Status: CLOSED CURRENTRELEASE
Product: Beaker
Classification: Community
Component: command line (Show other bugs)
0.9
Unspecified Unspecified
unspecified Severity unspecified (vote)
: 0.14
: ---
Assigned To: Dan Callaghan
tools-bugs
CommandLineEnhancement
: FutureFeature, TestCaseApproved, TestCaseProvided
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-01 23:57 EDT by Amit Saha
Modified: 2015-07-26 18:14 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-08 23:24:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Amit Saha 2012-10-01 23:57:47 EDT
Description of problem:

A --version option to show the current client version would be a good value addition.


Version-Release number of selected component (if applicable):


How reproducible:

Always.


Steps to Reproduce:
1. Install beaker client
2. bkr --version
3.
  
Actual results:

$ bkr --version
/home/bne/asaha/.beaker_client/config not found, using /etc/beaker/client.conf
Usage: bkr <command> [args] [--help]

bkr: error: no such option: --version


Expected results:

Should give the current client version.

Additional info:
Comment 1 Dan Callaghan 2013-06-18 21:28:43 EDT
On Gerrit: http://gerrit.beaker-project.org/2041
Comment 4 wangjing 2013-07-15 05:39:39 EDT
verified on beaker-devel Version - 0.13.2(20130715)-->pass
steps:
1. Install beaker client
2. bkr --version
results:
# bkr --version
0.13.2
Comment 6 Dan Callaghan 2013-08-08 23:24:23 EDT
Beaker 0.14.1 has been released.

Note You need to log in before you can comment on or make changes to this bug.