This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 862147 - SELinux is preventing /usr/bin/convert from 'unlink' accesses on the file magickIYUUr4.
SELinux is preventing /usr/bin/convert from 'unlink' accesses on the file mag...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:685fab5b6bc162f71fe6272bd49...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-02 00:05 EDT by D. Charles Pyle
Modified: 2012-10-09 12:52 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-09 12:52:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: type (9 bytes, text/plain)
2012-10-02 00:05 EDT, D. Charles Pyle
no flags Details
File: hashmarkername (14 bytes, text/plain)
2012-10-02 00:05 EDT, D. Charles Pyle
no flags Details

  None (edit)
Description D. Charles Pyle 2012-10-02 00:05:52 EDT
Description of problem:
Got this warning in abrt. I was not doing anything at the time it happened other than browsing the file system with Nautilus.

Additional info:
libreport version: 2.0.14
kernel:         3.6.0-0.rc7.git1.4.fc18.x86_64

description:
:SELinux is preventing /usr/bin/convert from 'unlink' accesses on the file magickIYUUr4.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that convert should be allowed unlink access on the magickIYUUr4 file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep convert /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023
:Target Context                unconfined_u:object_r:user_home_dir_t:s0
:Target Objects                magickIYUUr4 [ file ]
:Source                        convert
:Source Path                   /usr/bin/convert
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           ImageMagick-6.7.7.5-3.fc18.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.11.1-25.fc18.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Permissive
:Host Name                     (removed)
:Platform                      Linux (removed) 3.6.0-0.rc7.git1.4.fc18.x86_64 #1
:                              SMP Tue Sep 25 19:55:25 UTC 2012 x86_64 x86_64
:Alert Count                   1
:First Seen                    2012-10-01 22:03:55 MDT
:Last Seen                     2012-10-01 22:03:55 MDT
:Local ID                      3772c54d-e276-4633-95cf-42651c1c28b6
:
:Raw Audit Messages
:type=AVC msg=audit(1349150635.829:179): avc:  denied  { unlink } for  pid=10759 comm="convert" name="magickIYUUr4" dev="dm-1" ino=393710 scontext=unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:user_home_dir_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1349150635.829:179): arch=x86_64 syscall=unlink success=yes exit=0 a0=10eed90 a1=c2 a2=0 a3=7fffefc2ae60 items=0 ppid=10745 pid=10759 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 tty=(none) ses=10 comm=convert exe=/usr/bin/convert subj=unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023 key=(null)
:
:Hash: convert,thumb_t,user_home_dir_t,file,unlink
:
:audit2allow
:
:#============= thumb_t ==============
:allow thumb_t user_home_dir_t:file unlink;
:
:audit2allow -R
:
:#============= thumb_t ==============
:allow thumb_t user_home_dir_t:file unlink;
:
Comment 1 D. Charles Pyle 2012-10-02 00:05:54 EDT
Created attachment 620110 [details]
File: type
Comment 2 D. Charles Pyle 2012-10-02 00:05:56 EDT
Created attachment 620111 [details]
File: hashmarkername
Comment 3 Daniel Walsh 2012-10-09 12:52:56 EDT
This looks like you have a badly mislabeled homedir.

restorecon -R -v /home

Note You need to log in before you can comment on or make changes to this bug.