Bug 86216 - kudzu should make /dev/cdrom entries in same order as /dev/scd entries
kudzu should make /dev/cdrom entries in same order as /dev/scd entries
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kudzu (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-03-17 08:07 EST by Michael Wardle
Modified: 2014-03-16 22:35 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-29 15:54:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Wardle 2003-03-17 08:07:49 EST
Description of problem:
I have two ATAPI CD drives in my system, one as secondary master
(hdc) and one as secondary slave (hdd).  hdc is a DVD/CD-ROM drive,
hdd is a CD-RW drive.

On a clean install of Red Hat Linux 8.0.94, the CD-RW drive is
automatically configured as an IDE-SCSI drive by appending
"hdd=ide-scsi" to the kernel parameters at boot time, while the
DVD drive is left as a standard EIDE CD drive.

/dev/cdrom = /dev/hdc = hdc
/dev/cdrom1 = /dev/scd0 = hdd
/dev/cdwriter = /dev/sg0 = hdd

I decided I would like both ATAPI CD drives to use the IDE-SCSI
layer to keep things consistent, so I added "hdc=ide-scsi" to the
kernel parameters.  Afterward, I am left with:

/dev/cdrom = /dev/scd1 = hdd
/dev/cdrom1 = /dev/scd0 = hdc
/dev/cdwriter = /dev/sg1 = hdd

I would hope that I would instead have:

/dev/cdrom = /dev/scd0 = hdc
/dev/cdrom1 = /dev/scd1 = hdd
/dev/cdwriter = /dev/sg1 = hdd

I would expect this because it would:
- have the /dev/cdrom symbolic links in the same order as the
  IDE-SCSI devices (the first /dev/cdrom entry points to the first
  /dev/scd? entry, and so on)
- leave the /dev/cdrom symbolic links pointing to the same
  physical drive as they did before the DVD drive (hdc) was also
  made an IDE-SCSI device

I am filing this bug under kudzu, as I believe it is responsible
for hardware detection and modification of the /dev/cdrom symlinks.

This bug is probably unimportant, and you may decide to class it as
an enhancement rather than a defect.

Version-Release number of selected component (if applicable):
kudzu-0.99.96-1
Comment 1 Bill Nottingham 2005-03-29 15:54:57 EST
Closing bugs on older, no longer supported, releases. Apologies for any lack of
response.

In current trees this functionality is handled by HAL, fstab-sync, and the udev
configuration; the old code in kudzu is unlikely to change.

Note You need to log in before you can comment on or make changes to this bug.