Bug 862172 - Order of plugin/resource configuration properties incorrect after plug-in upgrade
Order of plugin/resource configuration properties incorrect after plug-in upg...
Status: CLOSED WONTFIX
Product: RHQ Project
Classification: Other
Component: Core Server (Show other bugs)
3.0.0,4.5
All All
unspecified Severity low (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-02 03:17 EDT by Andreas Veithen
Modified: 2017-03-18 17:13 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-03-18 17:13:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andreas Veithen 2012-10-02 03:17:26 EDT
Scenario: User upgrades an existing plug-in that introduces new (simple) properties in plug-in or resource configurations. In the plug-in these new properties have been inserted between existing properties (i.e. they have not been added at the end).

Result: After the plug-in upgrade, on the screens that display these plug-in or resource configurations, the properties are no longer shown in the order in which they have been declared in the plug-in descriptor.

Cause: In the rhq_config_prop_def table in the database, one can see that the order_index column is not updated correctly for existing properties during a plug-in upgrade. That is because ConfigurationMetadataManagerBean doesn't contain code to update that column for simple properties. The only code that updates order_index is related to map properties.
Comment 1 Charles Crouch 2012-10-03 08:33:42 EDT
Andreas, Can you confirm which version you are seeing this problem on? Have you tried with RHQ4.5?
Thanks
Comment 2 Andreas Veithen 2012-10-03 08:45:41 EDT
Yes, I observed that with a resource configuration while testing RHQ 4.5. I added the 3.0.0 version because I noticed the same issue with a plug-in configuration some time ago (although I didn't investigate the problem further at that time).
Comment 3 Heiko W. Rupp 2013-07-01 06:51:26 EDT
Andreas, as you already had a peek at the source -would you be able to contribute a patch?

Note You need to log in before you can comment on or make changes to this bug.