Bug 862208 - user cannnot take a vm from pool via restapi
user cannnot take a vm from pool via restapi
Status: CLOSED DUPLICATE of bug 864438
Product: oVirt
Classification: Community
Component: ovirt-engine-api (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Michael Pasternak
virt
:
Depends On:
Blocks: 864438
  Show dependency treegraph
 
Reported: 2012-10-02 05:49 EDT by Pieter Vogel
Modified: 2014-01-12 19:38 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 864438 (view as bug list)
Environment:
Last Closed: 2012-10-09 09:39:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pieter Vogel 2012-10-02 05:49:48 EDT
Description of problem: user cannnot create ticket for a machine from pool


Version-Release number of selected component (if applicable):
component: ovirt-engine-restapi
version: 3.1.0 beta2 

How reproducible: always


Steps to Reproduce:
1. grant user rights on pool
2. use restapi (with userlogin) to see on which pools user has rights. 
2. use restapi to take a vm from pool

  
Actual results: this is not implemented or documented.

Expected results: This should be possible because this is possible in userportal.


Additional info: The restapi is missing the possibility to "take vm" which is usually done in userportal. Now it is not possible to use restapi to connect to a machine from a pool.
Comment 1 Pieter Vogel 2012-10-02 06:05:58 EDT
bug should be in:
Product: Red Hat Enterprise Virtualization Manager
component: ovirt-engine-restapi

But I cann't move this bug.
Comment 2 Michael Pasternak 2012-10-02 06:24:38 EDT
Hi Pieter,

Can you please post request you have used against api and engine log?
Comment 3 Pieter Vogel 2012-10-02 07:41:16 EDT
That is the problem. This is not possible via restapi.

In the userportal a user can click on a pool to get a vm from that pool (take vm)
then the userportal shows a machine from that pool (eg pool-01)
then the user can click on that machine for a spice-connection.

Via restapi we try it as follows:

get as user a list of vm's
This results in a list of vm's the user has rights on. but their is no pool visible. and of course we don't have a possibility to "take a vm" and give user rights on a vm from a pool.


What we are missing in restapi:

1) howto see via restapi that a user has a userrole on a pool
2) take a vm from a pool (if a user didn't already have one)
Comment 4 Itamar Heim 2012-10-03 15:43:21 EDT
indeed.
the rest api was originally developed for admins, and pool 'allocate' wasn't relevant for admins.
now that user api was added, it was basedon the admin api, which didn't have this verb which should be added.

http://lists.ovirt.org/pipermail/engine-devel/2012-October/002572.html
Comment 5 Michael Pasternak 2012-10-09 09:39:50 EDT

*** This bug has been marked as a duplicate of bug 864438 ***

Note You need to log in before you can comment on or make changes to this bug.