Bug 862231 - Test plan searching crashes
Test plan searching crashes
Status: CLOSED DUPLICATE of bug 841299
Product: Fedora
Classification: Fedora
Component: python-nitrate (Show other bugs)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Petr Šplíchal
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2012-10-02 07:40 EDT by Martin Kudlej
Modified: 2016-05-31 21:43 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2012-12-06 11:24:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Martin Kudlej 2012-10-02 07:40:30 EDT
Description of problem:
>>> for plan in TestPlan.search(product__name="Red Hat Enterprise MRG",default_product_version="2.2"):
...   print plan.name
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/usr/lib/python2.7/site-packages/nitrate/api.py", line 2272, in search
    for hash in Nitrate()._server.TestPlan.filter(dict(query))]
  File "/usr/lib/python2.7/site-packages/nitrate/api.py", line 2249, in __init__
  File "/usr/lib/python2.7/site-packages/nitrate/api.py", line 2356, in _get
    self._type = PlanType(testplanhash["type_id"])
  File "/usr/lib/python2.7/site-packages/nitrate/api.py", line 731, in __init__
    "Not a valid Test Plan Type id: '{0}'".format(plantype))
nitrate.xmlrpc.NitrateError: Not a valid Test Plan Type id: '36'

Version-Release number of selected component (if applicable):
python-nitrate-0.9-0.fc16.noarch also visible in stable version 0.8

How reproducible:
Comment 1 Petr Šplíchal 2012-10-02 09:10:19 EDT
I believe this is a duplicate of bug 841299. Am I right, Martin? I
expect this to be fixed in about two to three weeks.
Comment 2 Martin Kudlej 2012-10-02 09:18:52 EDT
I don't know, I've just performed plan search.
Comment 3 Petr Šplíchal 2012-12-06 11:24:31 EST
I have verified that fix for bug 841299 resolves this issue as
well ---> closing as duplicate.

*** This bug has been marked as a duplicate of bug 841299 ***

Note You need to log in before you can comment on or make changes to this bug.