Bug 862240 - Bacula-storage-common wrongly removes alternatives for bcopy during update.
Summary: Bacula-storage-common wrongly removes alternatives for bcopy during update.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: bacula
Version: 6.3
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Lukáš Nykrýn
QA Contact: Tomas Dolezal
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-10-02 12:06 UTC by Lukáš Nykrýn
Modified: 2012-11-19 04:15 UTC (History)
3 users (show)

Fixed In Version: bacula-5.0.0-12.el6
Doc Type: Bug Fix
Doc Text:
Cause: Post scriptlet in bacula-storage-common do /usr/sbin/alternatives --remove bacula-sd. Consequence: Link to bcopy.{mysql,sqlite,postgresql} does not exist after update. Fix: Do not remove these links in storage-common package, but in storage-{mysql,sqlite,postgresql} Result: Link to bcopy.{mysql,sqlite,postgresql} does not disappear after update.
Clone Of:
Environment:
Last Closed: 2012-11-19 04:15:29 UTC
Target Upstream Version:


Attachments (Terms of Use)
Patch for spec file (1.83 KB, patch)
2012-10-02 12:08 UTC, Lukáš Nykrýn
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:1469 normal SHIPPED_LIVE bacula bug fix update 2012-11-19 09:14:28 UTC

Description Lukáš Nykrýn 2012-10-02 12:06:01 UTC
Description of problem:
Post scriptlet in bacula-storage-common do /usr/sbin/alternatives --remove bacula-sd.

Version-Release number of selected component (if applicable):
5.0.0-9

Steps to Reproduce:
1. update bacula-sd
2. /usr/sbin/alternatives --display bacula-sd
  
Actual results:
link does not exist

Expected results:
link should exist

Additional info:
Missing link can lead to problems during package removal.
Workaround for this issue is to manually add link before uninstall, for example:
/usr/sbin/alternatives --install /usr/sbin/bcopy bacula-sd /usr/sbin/bcopy.sqlite 40

Comment 1 Lukáš Nykrýn 2012-10-02 12:08:35 UTC
Created attachment 620258 [details]
Patch for spec file

Comment 10 errata-xmlrpc 2012-11-19 04:15:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-1469.html


Note You need to log in before you can comment on or make changes to this bug.