Bug 862252 - [PATCH] Squid doesn't reload on VPN up/down, or network down
[PATCH] Squid doesn't reload on VPN up/down, or network down
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: squid (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Michal Luscon
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-02 09:02 EDT by Matthew Booth
Modified: 2012-12-01 03:42 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-14 06:34:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix network manager dispatcher (582 bytes, patch)
2012-10-02 09:02 EDT, Matthew Booth
no flags Details | Diff

  None (edit)
Description Matthew Booth 2012-10-02 09:02:52 EDT
Created attachment 620276 [details]
Fix network manager dispatcher

Description of problem:
I use squid to reverse proxy some sites for a local network, some of which are only available over a VPN. If I start squid first, then the VPN, in that order, squid will not be able to access sites over the VPN. However, if I then cause squid to reconfigure it can access sites over the VPN. I assume squid is doing something with DNS caching, but haven't investigated.

I notice squid already has a network manager dispatcher script, but it appears a little unloved. Firstly it still uses /sbin/service. Secondly it only reloads on the "up" event.

The following works for me:

case "$2" in
        up|down|vpn-up|vpn-down)
                /bin/systemctl reload squid.service || :
                ;;
esac

I've attached a patched against rawhide git. This bug is applicable at least to F17, F18 and rawhide.

Version-Release number of selected component (if applicable):
squid-3.2.0.16-1.fc17.x86_64
Comment 1 Michal Luscon 2012-10-03 03:59:05 EDT
Thank you for your report and patch Matthew.
Comment 2 Fedora Update System 2012-10-26 11:15:48 EDT
squid-3.2.3-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/squid-3.2.3-2.fc18
Comment 3 Fedora Update System 2012-10-26 15:42:30 EDT
Package squid-3.2.3-2.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing squid-3.2.3-2.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16962/squid-3.2.3-2.fc18
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2012-11-20 08:18:37 EST
squid-3.2.3-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/squid-3.2.3-2.fc17
Comment 5 Fedora Update System 2012-11-20 10:28:53 EST
squid-3.2.3-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/squid-3.2.3-2.fc16
Comment 6 Fedora Update System 2012-12-01 03:31:36 EST
squid-3.2.3-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2012-12-01 03:42:56 EST
squid-3.2.3-2.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.