Bug 862269 - RFE: Save originating uri for downloaded files
RFE: Save originating uri for downloaded files
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jan Horak
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-02 09:51 EDT by Alexander Larsson
Modified: 2013-04-22 09:22 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-03 10:38:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Larsson 2012-10-02 09:51:19 EDT
It would be nice if firefox could save the original uri for downloaded files.
This is pretty easy to do with GIO using gvfs metadata. I implemented this in
webkit:

https://bugs.webkit.org/show_bug.cgi?id=95188

Its a pretty trivial patch, so it should be easy to add to firefox too.

We want to use this to e.g. show the original location in the download directory in nautilus.
Comment 1 Jan Horak 2012-10-03 10:38:06 EDT
We're going to track this issue on upstream: 
https://bugzilla.mozilla.org/show_bug.cgi?id=797349
Comment 2 Jan Horak 2013-04-22 03:54:52 EDT
FYI patch seems to introduce some regression, looks like g_file_set_attribute is blocking execution somehow:

https://bugzilla.mozilla.org/show_bug.cgi?id=860213#c7
Comment 3 Tomáš Bžatek 2013-04-22 09:22:39 EDT
(In reply to comment #2)
> FYI patch seems to introduce some regression, looks like
> g_file_set_attribute is blocking execution somehow:
> 
> https://bugzilla.mozilla.org/show_bug.cgi?id=860213#c7

It seems you're calling g_file_set_attribute() which is a synchronous call. Better to use g_file_set_attributes_async() instead.

Note You need to log in before you can comment on or make changes to this bug.