Bug 862278 - virt-v2v should not import VMs with dots in the VM name into RHEV
virt-v2v should not import VMs with dots in the VM name into RHEV
Status: CLOSED DEFERRED
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-v2v (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Matthew Booth
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-02 10:14 EDT by Dan Yasny
Modified: 2014-11-18 06:12 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-11-18 06:12:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Yasny 2012-10-02 10:14:55 EDT
Description of problem:
RHEV by default blocks the creation of VMs with dots "." in the VM name.
The reason is  we use the VM name to provide a hostname when a VM is deployed with sysprep, and dots aren't supported in hostnames.

In fact, according to the RFCs, only a-z and the hyphen char are supported:
http://en.wikipedia.org/wiki/Hostname#Restrictions_on_valid_host_names

virt-v2v, when importing a VM with dots in the VM name, puts it with these dots in RHEV.

What we should do is one of the following (I'd love to see them all implemented, with the user getting asked what to do):
1. replace dots (and other unsupported chars) with hyphens
2. stop conversion completely
3. ask for a VM name to be used on RHEV
Comment 2 RHEL Product and Program Management 2012-12-14 03:18:35 EST
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 5 Richard W.M. Jones 2014-11-18 06:12:45 EST
Virt-v2v needs to run on the latest Red Hat Enterprise Linux release
to ensure it can correctly read and modify new guest filesystem
features.  A new version of virt-v2v is now available for RHEL 7.1.

Before RHEL 7.1 is released, follow the instructions here to
install unsupported preview packages on top of RHEL 7.0:
https://www.redhat.com/archives/libguestfs/2014-May/msg00090.html

After RHEL 7.1 is released, virt-v2v will be available in
Technical Preview.

You can run virt-v2v in a single virtual machine.  Other
requirements are covered here:
http://libguestfs.org/virt-v2v.1.html#resource-requirements

If you find a missing feature or bug in the new version of virt-v2v
please file a bug using the following link:
https://bugzilla.redhat.com/enter_bug.cgi?product=Red%20Hat%20Enterprise%20Linux%207&component=libguestfs

Note You need to log in before you can comment on or make changes to this bug.