Bug 862281 - ccs: caution about overwriting semantics of most of set-commands (setfencedaemon, setdlm, setcman, setquorumd, setrm, setlogging, ...)
ccs: caution about overwriting semantics of most of set-commands (setfencedae...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: doc-Cluster_Administration (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Steven J. Levine
ecs-bugs
: Documentation
: 864118 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-02 10:17 EDT by Jan Pokorný
Modified: 2013-02-25 12:03 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-25 12:03:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Pokorný 2012-10-02 10:17:31 EDT
Currently, ccs implements overwriting semantics when setting properties
of some cluster configuration items.  Unfortunately, structure of Cluster
Administration guide may make users think the opposite as in section
5.5. Configuring Fence Devices, it contains these two separate
instructions:

To configure a value for the post_fail_delay attribute, execute
the following command:
> ccs -h host --setfencedaemon post_fail_delay=value

To configure a value for the post_join attribute, execute
the following command:
> ccs -h host --setfencedaemon post_join_delay=value

This operates with false assumption the semantics of set-commands is
additive.  If it would be true, the separation would be perfectly OK.
However, it is not;  running these two commands in sequence means
that with the second command, you will cancel the effect of the first
one (post_fail_delay property is dropped upon setting post_join_delay).

To unbend this, there should be no occurrence of configuring one item
(such as fence daemon) in more steps, i.e., everything set at once.

E.g.,:
> ccs -h host --setfencedaemon post_fail_delay=value post_join_delay=value

Additionally, there should probably be a warning box at the beginning
of the section explaining the implemented semantics and the danger
of loosing already configured properties with subsequent configuration
steps.

Adding Chris as he is the right person to discuss this with.
Comment 1 Chris Feist 2012-10-02 13:07:20 EDT
This is correct behavior for ccs, we will just need to add a note in the respective sections that setting those options will unset any other options.
Comment 2 Jan Pokorný 2012-10-08 11:58:06 EDT
*** Bug 864118 has been marked as a duplicate of this bug. ***
Comment 3 Steven J. Levine 2012-10-08 21:21:04 EDT
Chris:

The subject line of this BZ indicates this issue is true for the following commands:

setfencedaemon
setdlm
setcman
setquorumd
setrm
setlogging

etc.

What else is involved as part of the "etc."?
Comment 6 Chris Feist 2012-10-22 13:06:31 EDT
I believe these are all the commands that overwrite their previous settings:

--settotem
--setdlm
--setrm
--setcman
--setmulticast
--setaltmulticast
--setfencedaemon
--setlogging
--setquorumd

Thanks!
Chris

Note You need to log in before you can comment on or make changes to this bug.