Bug 862341 - fc17 modem-manager segfault at libglib with f3507g mobile broadband modem
fc17 modem-manager segfault at libglib with f3507g mobile broadband modem
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: ModemManager (Show other bugs)
17
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-02 13:01 EDT by luavi1
Modified: 2013-02-18 02:02 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-07 23:36:37 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
NetworkManager debug log (37.57 KB, application/octet-stream)
2012-11-26 11:56 EST, Vladimir
no flags Details
Abrt output, archived (206.51 KB, application/x-compressed-tar)
2012-11-26 11:59 EST, Vladimir
no flags Details
modem-manager debug log (38.70 KB, application/octet-stream)
2012-11-26 15:24 EST, Vladimir
no flags Details

  None (edit)
Description luavi1 2012-10-02 13:01:08 EDT
Description of problem:
modem-manager crashes irregularly. Needs reset by rf-kill to be functional again. 

Version-Release number of selected component (if applicable):
NetworkManager: 0.9.4.0-9.git20120521.fc17
ModemManager: version 0.6.0.0-1.fc17

How reproducible:
Run mobile broadband connection, irregular crashes follow.

Steps to Reproduce:
1. Start mobile broadband connection with NetworkManager or wvdial.
2. Irregularly, crash follows.

Actual results:
Bad user experience.

Expected results:
Stable connection.

Additional info:

Hardware:
Bus 002 Device 003: ID 0bdb:1900 Ericsson Business Mobile Networks BV F3507g Mobile Broadband Module


segfault logs below:
------------------------------------------------------------------------
1st example:

modem-manager[812]: segfault at 100000001 ip 000000318a26188f sp 00007fff1ad77200 error 4 in libglib-2.0.so.0.3200.4[318a200000+11d000]


--------------------------
2nd example, same segfault address:

Oct  2 19:40:11 m kernel: [  445.017149] modem-manager[812]: segfault at 100000001 ip 000000318a26188f sp 00007fff1ad77200 error 4 in libglib-2.0.so.0.3200.4[318a200000+11d000]
Oct  2 19:40:11 m NetworkManager[635]: <info> the modem manager disappeared
Oct  2 19:40:11 m NetworkManager[635]: <info> (wwan0): now unmanaged
Oct  2 19:40:11 m NetworkManager[635]: <info> (wwan0): device state change: activated -> unmanaged (reason 'removed') [100 10 36]
Oct  2 19:40:11 m NetworkManager[635]: <info> (wwan0): deactivating device (reason 'removed') [36]
Comment 2 Vladimir 2012-10-18 15:56:28 EDT
i've got rid of segfault message after uninstalling pptp and NetworkManager-pptp

it's not a solution for me, because i still need both broadband and pptp functionality.
Comment 3 Jirka Klimes 2012-10-19 09:23:21 EDT
Do you happen to have a stacktrace, possibly caught by abrt?

Or could you be run modem-manager in gdb? See https://live.gnome.org/NetworkManager/Debugging/#NM_3G_08_09
(add gdb before 'modem-manager --debug' in the third bullet)
Comment 4 Vladimir 2012-11-26 11:56:21 EST
Created attachment 652099 [details]
NetworkManager debug log

Done as follows:

Stop NetworkManager
killall -TERM modem-manager
modem-manager --debug
start NetworkManager again
Comment 5 Vladimir 2012-11-26 11:59:33 EST
Created attachment 652100 [details]
Abrt output, archived

I've archived contents of /var/spool/abrt/<cc-xxx>
Comment 6 Vladimir 2012-11-26 12:06:29 EST
Sorry for the late reply,
modem is not mine, I took it from a friend.

$ NetworkManager --version
0.9.4.0-9.git20120521.fc17


> Steps to Reproduce:
> 1. Start mobile broadband connection with NetworkManager or wvdial.
wvdial works good for me


> i've got rid of segfault message after uninstalling pptp and NetworkManager-pptp

I'm not sertainly sure about that.


Hardware used: 
ID 12d1:1001 Huawei Technologies Co., Ltd. E620 USB Modem
Comment 7 Vladimir 2012-11-26 15:24:42 EST
Created attachment 652253 [details]
modem-manager debug log

There is my gdb log.

I've stopped NetworkManager, killed modem-manager,
started modem-manager in gdb with args '--debug',
then started NetworkManager and tried to connect.

Also i've installed all the debuginfo packages, except for:
- dbus-libs-1.4.10-5.fc17.i686 
- glibc-2.15-57.fc17.i686

The last lines of log are here:

modem-manager[1981]: <debug> [1353960740.159579] [mm-generic-gsm.c:6205] simple_state_machine(): (ttyUSB0): simple connect state 0
modem-manager[1981]: <debug> [1353960740.160127] [mm-generic-gsm.c:6205] simple_state_machine(): (ttyUSB0): simple connect state 2
modem-manager[1981]: <debug> [1353960740.184166] [mm-at-serial-port.c:334] debug_log(): (ttyUSB2): <-- '<CR><LF>+COPS: 0,0,"UTEL3G\161",2<CR><LF><CR><LF>OK<CR><LF>'

Program received signal SIGSEGV, Segmentation fault.
g_utf8_validate (str=str@entry=0x0, max_len=max_len@entry=-1, end=end@entry=0x0) at gutf8.c:1629
1629	    p = fast_validate (str);
Missing separate debuginfos, use: debuginfo-install dbus-libs-1.4.10-5.fc17.i686 glibc-2.15-57.fc17.i686


Just in case, there are such versions of packages in my system:

glib
glib2-debuginfo-2.32.4-2.fc17.i686
glibc-headers-2.15-57.fc17.i686
glib-networking-2.32.3-1.fc17.i686
glib2-2.32.4-2.fc17.i686
glibc-devel-2.15-57.fc17.i686
glibc-2.15-57.fc17.i686
glib-1.2.10-36.fc17.i686
glibc-common-2.15-57.fc17.i686
glibmm24-2.32.1-1.fc17.i686
glib-devel-1.2.10-36.fc17.i686

pptp:
pptp-1.7.2-14.fc17.i686
NetworkManager-pptp-0.9.3.997-1.fc17.i6

Network-manager
NetworkManager-0.9.4.0-9.git20120521.fc17.i686
NetworkManager-glib-0.9.4.0-9.git20120521.fc17.i686
NetworkManager-gtk-0.9.4.0-9.git20120521.fc17.i686
NetworkManager-pptp-0.9.3.997-1.fc17.i686
NetworkManager-gnome-0.9.4.0-9.git20120521.fc17.i686
Comment 8 Jirka Klimes 2012-11-27 06:42:40 EST
Vladimir, thanks for the debugging logs.

The upstream contains fixes (MM_06 branch):
e07c2162d66ab1a2e938db48744fc00afd29c272
219424a6e2d017491a05ecbed661bccde3f991ef

but they are not in Fedora.

I'm going to update F17 package when I get access permissions.

Meanwhile, you can try the scratch build:
http://koji.fedoraproject.org/koji/taskinfo?taskID=4732936
Comment 9 Fedora Update System 2012-11-28 04:01:46 EST
ModemManager-0.6.0.0-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/ModemManager-0.6.0.0-2.fc17
Comment 10 Fedora Update System 2012-11-28 04:06:57 EST
ModemManager-0.6.0.0-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/ModemManager-0.6.0.0-2.fc18
Comment 11 Fedora Update System 2012-11-28 16:15:44 EST
Package ModemManager-0.6.0.0-2.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ModemManager-0.6.0.0-2.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-19331/ModemManager-0.6.0.0-2.fc18
then log in and leave karma (feedback).
Comment 12 Fedora Update System 2012-12-07 23:36:39 EST
ModemManager-0.6.0.0-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2013-01-31 08:18:18 EST
ModemManager-0.6.0.0-3.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/ModemManager-0.6.0.0-3.fc17
Comment 14 Fedora Update System 2013-01-31 08:18:41 EST
ModemManager-0.6.0.0-3.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/ModemManager-0.6.0.0-3.fc18
Comment 15 Fedora Update System 2013-02-18 02:01:39 EST
ModemManager-0.6.0.0-3.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 16 Fedora Update System 2013-02-18 02:02:42 EST
ModemManager-0.6.0.0-3.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.