Bug 862379 - gnome-desktop should require pixman
gnome-desktop should require pixman
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gnome-desktop (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Ray Strode [halfline]
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-02 14:31 EDT by Tomas Pelka
Modified: 2012-10-03 16:23 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-03 16:23:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Pelka 2012-10-02 14:31:47 EDT
Description of problem:
gnome-desktop should require pixman otherwise TPS Shared Libs test failed

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. no pixman installed
2. rpm -qf /usr/lib/libgnome-desktop-2.so | grep 'not found'
3.
  
Actual results:
libpixman-1.so.0 => not found

Expected results:
pixman should be installed as dependency

Additional info:
not a regression
Comment 1 RHEL Product and Program Management 2012-10-02 14:51:12 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 2 Ray Strode [halfline] 2012-10-02 16:05:30 EDT
I assume step 2 is actually

2. ldd /usr/lib/libgnome-desktop-2.so |grep 'not found'

but anyway gnome-desktop doesn't use pixman directly, so if it's linking to it, it's linking to it indirectly.  Does

rpm -q --requires cairo |grep pixman

return anything?
Comment 3 Tomas Pelka 2012-10-03 02:39:16 EDT
(In reply to comment #2)
> I assume step 2 is actually
> 
> 2. ldd /usr/lib/libgnome-desktop-2.so |grep 'not found'

Uh sorry I paste wrong line.

> 
> but anyway gnome-desktop doesn't use pixman directly, so if it's linking to
> it, it's linking to it indirectly.  Does
> 
> rpm -q --requires cairo |grep pixman
> 
> return anything?

rpm -q --requires cairo | grep pixman
libpixman-1.so.0()(64bit)  
libpixman-1.so.0
Comment 4 Tomas Pelka 2012-10-03 04:08:37 EDT
So you think it is transitional dependency (or how is it called)? In that case it could be closed.

Thanks
Tom
Comment 5 Ray Strode [halfline] 2012-10-03 10:43:46 EDT
well, there's some mystery here.  why wasn't pixman pulled in when you installed cairo ?
Comment 6 Tomas Pelka 2012-10-03 11:04:46 EDT
Well it is not a mistery since it is a stable system and anybody can unistall pixman for testing or so. We can close I believe.
Comment 7 Ray Strode [halfline] 2012-10-03 16:23:11 EDT
i don't know how they could without --nodeps, but you filed it, you get to say if it gets closed :-)

Note You need to log in before you can comment on or make changes to this bug.