Bug 862537 - Fedora 18 Beta TC1 DVD fails to boot
Fedora 18 Beta TC1 DVD fails to boot
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
18
All Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Dennis Gilmore
Bill Nottingham
AcceptedBlocker
:
Depends On:
Blocks: F18Beta/F18BetaBlocker
  Show dependency treegraph
 
Reported: 2012-10-03 03:43 EDT by Dan Mashal
Modified: 2014-03-16 23:32 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-05 04:35:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
screenshot (37.16 KB, image/png)
2012-10-03 03:43 EDT, Dan Mashal
no flags Details
boot log with rd.debug rd.loglevel=77 (933.80 KB, text/plain)
2012-10-03 06:39 EDT, Martin Banas
no flags Details
ls -l /dev/disk/by-* (26.35 KB, image/png)
2012-10-03 16:35 EDT, Dan Mashal
no flags Details

  None (edit)
Description Dan Mashal 2012-10-03 03:43:58 EDT
Created attachment 620659 [details]
screenshot

Description of problem:

Fedora 18 Beta TC1 DVD fails to boot

Version-Release number of selected component (if applicable):

Fedora 18 Beta TC1 DVD ISO

How reproducible:

Try to boot Fedora 18 DVD ISO fails
Comment 1 Andre Robatino 2012-10-03 04:57:36 EDT
Both 32- and 64-bit DVDs fail to boot. Both netinsts boot okay.
Comment 2 Joachim Backes 2012-10-03 05:19:58 EDT
Same problem (see  #862568) here in VirtualBox and in real machine.
Comment 3 Joachim Backes 2012-10-03 05:21:29 EDT
(In reply to comment #2)
> Same problem (see  #862568) here in VirtualBox and in real machine.

I only tested the 64bit version.
Comment 4 satellitgo 2012-10-03 05:29:54 EDT
netinstall i386 installs fine (gnome) but keeps trying to add additional file:
:lang=c
VirtualBox install
Comment 5 satellitgo 2012-10-03 05:32:23 EDT
(In reply to comment #4)
Also saw DVD fail to boot - drop to dracut# Burned DVD x86-64
> netinstall i386 installs fine (gnome) but keeps trying to add additional
> file:
> :lang=c
> VirtualBox install
Comment 6 Martin Banas 2012-10-03 06:39:12 EDT
Created attachment 620744 [details]
boot log with rd.debug rd.loglevel=77

Attaching boot.log in plaintext, with some debug messages enabled.
Comment 7 Harald Hoyer 2012-10-03 11:56:13 EDT
What does the command in the dracut shell output:

# ls -l /dev/disk/by-*
Comment 8 Josh Boyer 2012-10-03 12:30:17 EDT
The kernel command line is:

BOOT_IMAGE=/images/pxeboot/vmlinuz inst.stage2=hd:LABEL=Fedora\x2018-Beta-TC1\x20x86_64

The label on the media (I believe) is:

Fedora_18-Beta-TC1_x86_64

So, I'm guessing the label here doesn't match the config which is why it can't find root.

grub2 was fixed to handle spaces in labels, but apparently pungi was told to use underscores instead of spaces?  I really have no idea, but this seems to be a left vs. right hand issue.
Comment 9 satellitgo 2012-10-03 12:59:59 EDT
f18-Beta-TC1-x86-64 DVD boots and installs Gnome from DVD when kernel command line is edited to:
LABEL=Fedora_18-Beta-TC1_x86_64

Thanks
Comment 10 satellitgo 2012-10-03 13:47:49 EDT
(In reply to comment #9)
> f18-Beta-TC1-x86-64 DVD boots and installs Gnome from DVD when kernel
> command line is edited to:
> LABEL=Fedora_18-Beta-TC1_x86_64
Installed gnome 3.6.0-1 sucessfully to USB HD
Comment 11 Dan Mashal 2012-10-03 16:34:37 EDT
(In reply to comment #7)
> What does the command in the dracut shell output:
> 
> # ls -l /dev/disk/by-*

screenshot attached.
Comment 12 Dan Mashal 2012-10-03 16:35:10 EDT
Created attachment 621137 [details]
ls -l /dev/disk/by-*
Comment 13 Reartes Guillermo 2012-10-03 21:24:07 EDT
I can confirm that the comment #9 description is accurate.
I can reach anaconda with such method on my kvm guests.
Comment 14 Adam Williamson 2012-10-04 14:25:02 EDT
Discussed at 2012-10-04 blocker review meeting: http://meetbot.fedoraproject.org/fedora-qa/2012-10-04/f18-beta-blocker-review-2.1.2012-10-04-16.00.log.txt .  Accepted as a blocker per criterion "The installer must boot (if appropriate) and run on all primary architectures, with all system firmware types that are common on those architectures, from default live image, DVD, and boot.iso install media when written to an optical disc and when written to a USB stick with at least one of the officially supported methods". We believe the fix for this is already known and TC2 should work (will land tomorrow).
Comment 15 Bill Nottingham 2012-10-04 14:31:45 EDT
Given comment #9, looks like something went wrong in the releng/compose side that caused a mismatch.
Comment 16 Andre Robatino 2012-10-04 16:29:53 EDT
All 18 Beta TC2 install images (32- and 64-bit DVD and netinst) boot okay (tested in VirtualBox).
Comment 17 Adam Williamson 2012-10-05 04:35:08 EDT
We can close this then. There's no package to go stable, it was just a releng process snafu.

Note You need to log in before you can comment on or make changes to this bug.