Bug 862542 - fedora-gnat-project-common has broken dependency on s390 (gcc-gnat)
fedora-gnat-project-common has broken dependency on s390 (gcc-gnat)
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: fedora-gnat-project-common (Show other bugs)
17
s390 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Björn Persson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-03 03:57 EDT by Pavel Zhukov
Modified: 2012-12-19 15:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-19 15:11:10 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pavel Zhukov 2012-10-03 03:57:07 EDT
Description of problem:
fedora-gnat-project-common doesn't contain ExclusiveArch tag


Version-Release number of selected component (if applicable):
# uname -a 
Linux fedora 3.3.4-5.fc17.s390x #1 SMP Mon May 14 13:16:10 EDT 2012 s390x s390x s390x GNU/Linux

# yum install fedora-gnat-project-common.noarch
Loaded plugins: langpacks, presto, refresh-packagekit
Resolving Dependencies
--> Running transaction check
---> Package fedora-gnat-project-common.noarch 0:3.4-1.fc17 will be installed
--> Processing Dependency: libgnat-static for package: fedora-gnat-project-common-3.4-1.fc17.noarch
--> Processing Dependency: gcc-gnat for package: fedora-gnat-project-common-3.4-1.fc17.noarch
--> Finished Dependency Resolution
Error: Package: fedora-gnat-project-common-3.4-1.fc17.noarch (fedora)
           Requires: libgnat-static
Error: Package: fedora-gnat-project-common-3.4-1.fc17.noarch (fedora)
           Requires: gcc-gnat
 You could try using --skip-broken to work around the problem


P.S. Do you know resons why there is not gcc-gnat on s390?
Comment 1 Björn Persson 2012-10-04 15:25:03 EDT
So if I understand you right you want fedora-gnat-project-common excluded from repositories where gcc-gnat and libgnat aren't available. I found some emails in the devel list archive stating that ExcludeArch can be used for this purpose, even in noarch packages, so there is hope that ExclusiveArch works the same way. Let's try it and see.

Is it enough if I make this change in Rawhide, or is the problem so severe that I should submit updates to all releases even though the primary architectures don't need any updates? Or will it help you if I build in Koji on the release branches but don't submit updates? (I know very little about how secondary architectures are made.)

> P.S. Do you know resons why there is not gcc-gnat on s390?

No, I don't know. Do you know if it's supposed to work? I guess some porting would be needed in low-level parts of Libgnat, and if there's anything Ada-specific in the code generation, then those parts must of course be ported to the s390 instruction set. Has all of that been done upstream, in GCC?
Comment 2 Pavel Zhukov 2012-10-05 06:10:18 EDT
(In reply to comment #1)
> So if I understand you right you want fedora-gnat-project-common excluded
> from repositories where gcc-gnat and libgnat aren't available. 
Probably yes. Because I don't like "broken dependencies"  message :)

> Is it enough if I make this change in Rawhide, or is the problem so severe
> that I should submit updates to all releases even though the primary
> architectures don't need any updates? Or will it help you if I build in Koji
> on the release branches but don't submit updates? (I know very little about
> how secondary architectures are made.)

I think there is no s390 in koji and in autoQA as well.  It's not big problem to update only rawhide. 

> > P.S. Do you know resons why there is not gcc-gnat on s390?
> 
> No, I don't know. Do you know if it's supposed to work? I guess some porting
> would be needed in low-level parts of Libgnat, and if there's anything
> Ada-specific in the code generation, then those parts must of course be
> ported to the s390 instruction set. Has all of that been done upstream, in
> GCC?

Debian contains gcc-gnat 4.X for example. GCC-gnat >3.2 has been dropped from RHEL and Fedora.
Comment 3 Fedora Update System 2012-10-05 18:37:42 EDT
fedora-gnat-project-common-3.5-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/fedora-gnat-project-common-3.5-2.fc18
Comment 4 Björn Persson 2012-10-05 18:42:15 EDT
(In reply to comment #2)
> I think there is no s390 in koji and in autoQA as well.  It's not big
> problem to update only rawhide. 

I made the change in Rawhide and F18. Please test it and give karma in Bodhi.

> Debian contains gcc-gnat 4.X for example.

OK, then it's probably just that no one who has access to an s390 system has done the work to bootstrap GNAT on Fedora.
Comment 5 Fedora Update System 2012-10-06 01:26:51 EDT
Package fedora-gnat-project-common-3.5-2.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing fedora-gnat-project-common-3.5-2.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-15513/fedora-gnat-project-common-3.5-2.fc18
then log in and leave karma (feedback).

Note You need to log in before you can comment on or make changes to this bug.