Bug 862546 - STARTER_RLIMIT_AS usage very confusing
STARTER_RLIMIT_AS usage very confusing
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: condor (Show other bugs)
17
All Linux
unspecified Severity low
: ---
: ---
Assigned To: matt
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-03 04:16 EDT by Bert DeKnuydt
Modified: 2012-11-04 05:46 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-04 05:46:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Condor 3304 None None None 2012-11-04 05:46:53 EST

  None (edit)
Description Bert DeKnuydt 2012-10-03 04:16:57 EDT
Description of problem:

The old condor problem: the documentation does not specify
in what units STARTER_RLIMIT_AS is to be expressed. 

In this case it looks like Terabytes; highly unlikely I think... 

Version-Release number of selected component (if applicable):

condor-7.9.1-0.1.fc17.2.

How reproducible:

Always

Steps to Reproduce:
1. Put STARTER_RLIMIT_AS = 1 in the config file
2. Run a job
3. Grep through the StarterLog
   > grep virtual StarterLog
   > StarterLog.slot1_1:10/03/12 09:51:48 Setting job's virtual memory rlimit to 1048576 megabytes
  
Actual results:

> StarterLog.slot1_1:10/03/12 09:51:48 Setting job's virtual memory rlimit to 1048576 megabytes  

Expected results:

Some consistent scheme for addressing amounts of memory all over condor.
Like: all amounts are bytes, unless tagged with k, M, G of T.

Additional info:

When you specify 0, it reports 
  'Setting job's virtual memory rlimit to 0 megabytes'
but that is obviously not true, as that would prevent any job from starting.

Probably '0' means, 'leave it alone', but it should be reported as such then.
Comment 1 Matthew Farrellee 2012-11-04 05:46:53 EST
Moved upstream - https://condor-wiki.cs.wisc.edu/index.cgi/tktview?tn=3304

Note You need to log in before you can comment on or make changes to this bug.