Bug 862559 - [RHEVM] [backend] [Host Networking] wrong error message on bond interface change
[RHEVM] [backend] [Host Networking] wrong error message on bond interface change
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
x86_64 All
medium Severity medium
: ---
: ---
Assigned To: Mike Kolesnik
Martin Pavlik
network
:
Depends On: 875487 888315
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-03 04:46 EDT by Martin Pavlik
Modified: 2016-02-10 14:55 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-05 02:59:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
vdsm.log + engine.log (16.61 KB, application/x-gzip)
2012-10-03 04:46 EDT, Martin Pavlik
no flags Details
screenshot 1 (170.08 KB, image/png)
2012-10-03 04:47 EDT, Martin Pavlik
no flags Details

  None (edit)
Description Martin Pavlik 2012-10-03 04:46:04 EDT
Created attachment 620692 [details]
vdsm.log + engine.log

Description of problem:

If a user detaches network used by running VM from bond, destroys the bond (e.g bond4) and creates a new bond with same interfaces, same options but different name (e.g. bond 3). The following error message appears:

Error while executing action Setup Networks: Interface name can't be found

It would be better if the user got clear message which describes the problem and its solution. It should be same message which appears if user disconnects the network and does not attach it to the new bond:

Cannot setup Networks. The following VMs are actively using the Logical Network: Fedora, w-xp-java, fedora17, rhel63, w7-virtio. Please stop the VMs and try again.

Version-Release number of selected component (if applicable):
Red Hat Enterprise Virtualization Manager Version: '3.1.0-18.el6ev' 

How reproducible:
100%

Steps to Reproduce:
1. create logical network
2. attach the logical network to bond on host (e.g. bond0)
3. create VM which uses network from step 1, run the VM
4. hosts->your host-> setup host networks
   a)break bond from step 2
   b)take previously bonded interfaces and create a new bond (e.g. bond1) with same options as bond0 had
   c) assign network from step 1 to newly created bond
   d) click ok
  
Actual results:
Error while executing action Setup Networks: Interface name can't be found

Expected results:
Cannot setup Networks. The following VMs are actively using the Logical Network: $VM1, $VM2. Please stop or migrate the VMs and try again.

Additional info:
2012-10-03 10:39:14,396 ERROR [org.ovirt.engine.core.vdsbroker.vdsbroker.BrokerCommandBase] (ajp-/127.0.0.1:8009-11) [3aa0be82] Failed in SetupNetworksVDS method
2012-10-03 10:39:14,397 ERROR [org.ovirt.engine.core.vdsbroker.vdsbroker.BrokerCommandBase] (ajp-/127.0.0.1:8009-11) [3aa0be82] Error code ERR_BAD_NIC and error message VDSGenericException: VDSErrorException: Failed to SetupNetworksVDS, error = delNetwork: ['p1p1', 'p1p2', 'vnet1'] are not all nics enslaved to bond0
2012-10-03 10:39:14,397 ERROR [org.ovirt.engine.core.vdsbroker.vdsbroker.BrokerCommandBase] (ajp-/127.0.0.1:8009-11) [3aa0be82] org.ovirt.engine.core.vdsbroker.vdsbroker.VDSErrorException: VDSGenericException: VDSErrorException: Failed to SetupNetworksVDS, error = delNetwork: ['p1p1', 'p1p2', 'vnet1'] are not all nics enslaved to bond0
2012-10-03 10:39:14,397 ERROR [org.ovirt.engine.core.vdsbroker.VDSCommandBase] (ajp-/127.0.0.1:8009-11) [3aa0be82] Command SetupNetworksVDS execution failed. Exception: VDSErrorException: VDSGenericException: VDSErrorException: Failed to SetupNetworksVDS, error = delNetwork: ['p1p1', 'p1p2', 'vnet1'] are not all nics enslaved to bond0
2012-10-03 10:39:14,397 ERROR [org.ovirt.engine.core.bll.SetupNetworksCommand] (ajp-/127.0.0.1:8009-11) [3aa0be82] Command org.ovirt.engine.core.bll.SetupNetworksCommand throw Vdc Bll exception. With error message VdcBLLException: org.ovirt.engine.core.vdsbroker.vdsbroker.VDSErrorException: VDSGenericException: VDSErrorException: Failed to SetupNetworksVDS, error = delNetwork: ['p1p1', 'p1p2', 'vnet1'] are not all nics enslaved to bond0
Comment 1 Martin Pavlik 2012-10-03 04:47:38 EDT
Created attachment 620693 [details]
screenshot 1
Comment 3 Mike Kolesnik 2013-02-05 02:22:45 EST
I tried this scenario, getting the error: Error while executing action Setup Networks: Network is currently being used

This seems good to me, since you didn't actually remove the network from the host but you can't do the setup networks since the network is used by the running VM.

What do you think?
Comment 4 Martin Pavlik 2013-02-05 02:38:26 EST
It seems to be close enough.
Comment 5 Mike Kolesnik 2013-02-05 02:59:49 EST
Closing this bug as it seems the message is OK now

Note You need to log in before you can comment on or make changes to this bug.