Bug 862566 - ares_parse_aaaa_reply can leak memory
ares_parse_aaaa_reply can leak memory
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: c-ares (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Jakub Hrozek
Jakub Prokes
:
Depends On:
Blocks: 1061410
  Show dependency treegraph
 
Reported: 2012-10-03 04:54 EDT by Jakub Hrozek
Modified: 2014-10-14 02:44 EDT (History)
4 users (show)

See Also:
Fixed In Version: c-ares-1.10.0-1.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-14 02:44:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jakub Hrozek 2012-10-03 04:54:27 EDT
Description of problem:
Upstream commit 50f25d8a4b2d16f4c5e0ef620238688b7a315c7a fixed a memory leak in ares_parse_aaaa_reply in the case IPv6 resolution succeeded. We should be aware of the issue.

Version-Release number of selected component (if applicable):
latest RHEL6

How reproducible:
valgrind, code inspection

Additional info:
https://github.com/bagder/c-ares/commit/50f25d8a4b2d16f4c5e0ef620238688b7a315c7a
Comment 3 Jakub Hrozek 2014-05-19 14:45:47 EDT
Petr, this bug is solved by the rebase tracked by bz #1077544, can you add qa_ack?
Comment 8 Jakub Hrozek 2014-08-21 06:07:14 EDT
Sorry, there were two leaks and one of them got reverted. The other should still be valid, though:
https://github.com/bagder/c-ares/commit/50f25d8a4b2d16f4c5e0ef620238688b7a315c7a

Can you try with an address that resolves to CNAMEs only? Looking at the code, that should do the trick.
Comment 9 Jakub Hrozek 2014-08-21 06:08:10 EDT
(In reply to Jakub Hrozek from comment #8)
> Sorry, there were two leaks and one of them got reverted. The other should
> still be valid, though:
> https://github.com/bagder/c-ares/commit/
> 50f25d8a4b2d16f4c5e0ef620238688b7a315c7a
> 

Gah, this is the one that got reverted actually. This is the valid one:
https://github.com/bagder/c-ares/commit/bffd67f16a8f42fe6dbf79ab2e39d92eea05c8a6
Comment 11 errata-xmlrpc 2014-10-14 02:44:36 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1478.html

Note You need to log in before you can comment on or make changes to this bug.