Bug 862572 - System will freeze when you try to switch to virtual terminal
System will freeze when you try to switch to virtual terminal
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xorg-x11 (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Adam Jackson
Desktop QE
:
Depends On:
Blocks: rhel59rtt
  Show dependency treegraph
 
Reported: 2012-10-03 05:00 EDT by Ľuboš Kardoš
Modified: 2016-07-31 21:26 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-02 09:17:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Xorg.0.log from frozen sytem (31.36 KB, text/x-log)
2012-11-05 05:16 EST, Ľuboš Kardoš
no flags Details
Xorg.0.log.old from frozen sytem (12.73 KB, application/octet-stream)
2012-11-05 05:16 EST, Ľuboš Kardoš
no flags Details

  None (edit)
Description Ľuboš Kardoš 2012-10-03 05:00:57 EDT
Description of problem:
When you try to switch from desktop enviroment (7th virtual terminal) to the first virtual terminal system will freeze.


Version-Release number of selected component (if applicable):
xorg-x11-server-Xorg-1.1.1-48.96.el5

How reproducible:
Always reproducible in virt-manager (qemu-kvm), similar problems also on bare-metal machine.


Steps to Reproduce:
1. Install RHEL5.9-Client-20120926.0 default package set.
2. Reboot to system, login via gdm.
3. Try to switch to the first virtual terminal ( press ctrl+alt+f1 on bare-metal machine or use menu "Send Key -> Ctrl+Alt+F1" in virt-manager).
  
Actual results:
System will freeze.


Expected results:
Successful switching to virtual terminal.

Additional info:
When I downgraded xorg-x11-server-Xorg-1.1.1-48.96.el5 to xorg-x11-server-Xorg-1.1.1-48.93.el5 (package in previous rel-eng compose of RHEL5.9) and rebooted system then this problem disappeared and I was able to switch to virtual terminal.
Comment 1 RHEL Product and Program Management 2012-10-03 05:08:49 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 2 Adam Jackson 2012-11-02 17:20:52 EDT
I'm not sure how that can be possible.  The totality of the changes between 93 and 96 are:

* Fri Sep 21 2012 Dave Airlie <airlied@redhat.com> 1.1.1-48.96
- fix prgn free to use correct api (#854634)

* Fri Sep 21 2012 Adam Jackson <ajax@redhat.com> 1.1.1-48.95
- xserver-1.1.1-more-regen-leaks.patch: Fix memory leaks at regeneration in
  XKB, root cursor, and GLX. (#498357)

* Tue Sep 18 2012 Dave Airlie <airlied@redhat.com> 1.1.1-48.94
- xserver-1.1.1-fix-prgn-leak.patch: Fix a region leak in composite wrapper (#854634)

None of that code is on the VT switch path at all.

When you say "system will freeze", do you just mean graphics disappears?  Can you still ssh into the machine?  If so, is there anything interesting in /var/log/Xorg.0.log{,.old} ?
Comment 3 Ľuboš Kardoš 2012-11-05 05:15:29 EST
I see graphics but I am not able to move with mouse cursor and pressing keys on keyboard is ignored by system.

Yes, I can ssh into the machine. I attach Xorg.0.log and Xorg.0.log.old.
Comment 4 Ľuboš Kardoš 2012-11-05 05:16:15 EST
Created attachment 638461 [details]
Xorg.0.log from frozen sytem
Comment 5 Ľuboš Kardoš 2012-11-05 05:16:46 EST
Created attachment 638462 [details]
Xorg.0.log.old from frozen sytem
Comment 6 Adam Jackson 2012-11-05 13:15:22 EST
Can you reproduce this failure with kernel -342 or older?  I suspect this may be related to bug #871692.
Comment 7 Ľuboš Kardoš 2012-11-07 08:05:28 EST
Yes, I can reproduce with older kernel (kernel-2.6.18-339.el5.i686.rpm).
Comment 8 RHEL Product and Program Management 2014-03-07 08:43:24 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 9 RHEL Product and Program Management 2014-06-02 09:17:54 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Note You need to log in before you can comment on or make changes to this bug.