Bug 862597 - Description of kernel.msgmax and kernel.msgmnb wrong in /etc/sysctl.conf
Description of kernel.msgmax and kernel.msgmnb wrong in /etc/sysctl.conf
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: initscripts (Show other bugs)
5.8
All Linux
unspecified Severity low
: rc
: ---
Assigned To: Lukáš Nykrýn
qe-baseos-daemons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-03 06:48 EDT by Michael Firth
Modified: 2014-09-08 06:07 EDT (History)
4 users (show)

See Also:
Fixed In Version: initscripts-8.45.44-1.el5
Doc Type: Bug Fix
Doc Text:
The description of the kernel.msgmax parameter "Controls the default maxmimum size of a mesage queue" and the kernel.msgmnb parameter "Controls the maximum size of a message, in bytes" in the default /etc/sysctl.conf were wrong - the actual definitions are the opposite way around.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-30 18:01:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Firth 2012-10-03 06:48:34 EDT
Description of problem:
The description of the kernel.msgmax parameter "Controls the default maxmimum size of a mesage queue" and the kernel.msgmnb parameter "Controls the maximum size of a message, in bytes" in the default /etc/sysctl.conf are wrong - the actual definitions are the opposite way around.
This causes confusion for anyone trying to customise the SYS V message queue behaviours.
It would also be useful to have the value for kernel.msgmni in the default file, as the kernel default for this (16) is incredibly low

Version-Release number of selected component (if applicable):
8.45.42-1

How reproducible:
Completely

Steps to Reproduce:
1. cat /etc/sysctl.conf
2. read the descriptions of the two fields
  
Actual results:
# Controls the maximum size of a message, in bytes
kernel.msgmnb = 65536

# Controls the default maxmimum size of a mesage queue
kernel.msgmax = 65536


Expected results:
# Controls the default maxmimum size of a message queue
kernel.msgmnb = 65536

# Controls the maximum size of a message, in bytes
kernel.msgmax = 65536


Additional info:
Comment 1 RHEL Product and Program Management 2013-04-04 08:33:26 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 7 errata-xmlrpc 2013-09-30 18:01:34 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1300.html

Note You need to log in before you can comment on or make changes to this bug.