Bug 862600 - Upgrade to dhclient-4.2.4-P2.fc16 breaks IPv4 ethernet
Upgrade to dhclient-4.2.4-P2.fc16 breaks IPv4 ethernet
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dhcp (Show other bugs)
16
i686 Linux
urgent Severity urgent
: ---
: ---
Assigned To: Jiri Popelka
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-03 07:07 EDT by Jonathan Kamens
Modified: 2012-10-08 04:24 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-08 04:24:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2012-10-03 07:07:06 EDT
After upgrading this morning to dhclient-4.2.4-1.P2.fc16 and rebooting, dhclient obtained and logged to /var/log/messages an IP address for eth0 but didn't configure the address onto the device. I had to do "ifconfig eth0 <addr> netmask 255.255.0.0" and then "route add default dev eth0 gw <gateway-from-leases-file>" to get my network up and running. Downgrading to the older dhclient, dhcp-libs and dhcp-client fixes the problem.

I have SELinux enabled, but there's nothing in /var/log/audit/audit.log to suggest an SELinux issue.
Comment 1 Jiri Popelka 2012-10-03 07:47:43 EDT
Whoops !
Comment 2 Fedora Update System 2012-10-03 08:01:11 EDT
dhcp-4.2.4-3.P2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/dhcp-4.2.4-3.P2.fc16
Comment 3 Jiri Popelka 2012-10-03 08:08:42 EDT
Jonathan, can you try these builds
http://koji.fedoraproject.org/koji/buildinfo?buildID=357937

and leave a karma at
https://admin.fedoraproject.org/updates/dhcp-4.2.4-3.P2.fc16

Thanks
Comment 4 Chris C. Chen 2012-10-04 03:48:07 EDT
It looks like /sbin/dhclient hardcoded to execve /usr/sbin/dhclient-script, while the script is actually in /sbin/dhclient-script.  A sym-link to the actual file fixed my fc16.

/var/log/messages:

>Oct  3 04:57:55 localhost dhclient[1152]: execve (/usr/sbin/dhclient-script, ...): No such file or directory
>Oct  3 04:57:55 localhost dhclient[1151]: DHCPREQUEST on eth0 to 255.255.255.255 port 67
>Oct  3 04:57:55 localhost dhclient[1151]: DHCPACK from 192.168.1.1
>Oct  3 04:57:55 localhost dhclient[1153]: execve (/usr/sbin/dhclient-script, ...): No such file or directory
>Oct  3 04:57:55 localhost dhclient[1151]: bound to 192.168.1.123 -- renewal in 37016 seconds.
Comment 5 Shannon Hughes 2012-10-05 11:51:13 EDT
seeing the same issue on my fedora 16 client. hitting the problem with linked to /usr/sbin/dhclient-script as chris chen indicated above.
Comment 6 Jiri Popelka 2012-10-08 04:24:21 EDT
https://admin.fedoraproject.org/updates/dhcp-4.2.4-3.P2.fc16
has been in stable since 2012-10-04

Note You need to log in before you can comment on or make changes to this bug.