Bug 862602 - Anaconda doesn't show final screen: SIGCHLD caught when trying to start the X server.
Anaconda doesn't show final screen: SIGCHLD caught when trying to start the X...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
Unspecified Unspecified
medium Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 782468
  Show dependency treegraph
 
Reported: 2012-10-03 07:18 EDT by Martin Banas
Modified: 2013-09-19 09:09 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-04 11:39:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda.log (4.62 KB, text/plain)
2012-10-03 07:18 EDT, Martin Banas
no flags Details
anaconda-yum.conf (243 bytes, text/plain)
2012-10-03 07:19 EDT, Martin Banas
no flags Details
ifcfg.log (1.79 KB, text/plain)
2012-10-03 07:19 EDT, Martin Banas
no flags Details
packaging.log (188.94 KB, text/plain)
2012-10-03 07:20 EDT, Martin Banas
no flags Details
program.log (43.11 KB, text/plain)
2012-10-03 07:21 EDT, Martin Banas
no flags Details
storage.log (118.37 KB, text/plain)
2012-10-03 07:21 EDT, Martin Banas
no flags Details
syslog (70.19 KB, text/plain)
2012-10-03 07:22 EDT, Martin Banas
no flags Details

  None (edit)
Description Martin Banas 2012-10-03 07:18:16 EDT
Description of problem:
Anaconda doesn't show the final screen, it turns black when final screen should be shown. This is what I see in anaconda.log:
07:09:21,709 ERR anaconda: unknown selinux state: None
11:09:21,775 ERR anaconda: Error running metacity: SIGCHLD caught when trying to start the X server.
11:09:21,777 ERR anaconda: Problems running the window manager: Error running metacity: SIGCHLD caught when trying to start the X server.


Version-Release number of selected component (if applicable):
Fedora-18-Beta-TC1
anaconda-18.11
virt-manager-0.9.4-1.fc17.noarch

How reproducible:
Not always reproducible

Steps to Reproduce:
1. Start Fedora-18 installation
2. Select default partitioning, do not make other modifications
3. Start installation, watch the progress.
  
Actual results:
Once the installation is finished, the screen turns black:
Following messages are in anaconda.log:
07:09:21,709 ERR anaconda: unknown selinux state: None
11:09:21,775 ERR anaconda: Error running metacity: SIGCHLD caught when trying to start the X server.
11:09:21,777 ERR anaconda: Problems running the window manager: Error running metacity: SIGCHLD caught when trying to start the X server.

Expected results:
User should be able to hit "Reboot" button.

Additional info:
Comment 1 Martin Banas 2012-10-03 07:18:38 EDT
Created attachment 620752 [details]
anaconda.log
Comment 2 Martin Banas 2012-10-03 07:19:04 EDT
Created attachment 620753 [details]
anaconda-yum.conf
Comment 3 Martin Banas 2012-10-03 07:19:27 EDT
Created attachment 620754 [details]
ifcfg.log
Comment 4 Martin Banas 2012-10-03 07:20:59 EDT
Created attachment 620755 [details]
packaging.log
Comment 5 Martin Banas 2012-10-03 07:21:22 EDT
Created attachment 620756 [details]
program.log
Comment 6 Martin Banas 2012-10-03 07:21:47 EDT
Created attachment 620757 [details]
storage.log
Comment 7 Martin Banas 2012-10-03 07:22:08 EDT
Created attachment 620758 [details]
syslog
Comment 8 Jesse Keating 2012-10-03 12:22:33 EDT
Was there no X log?
Comment 9 Martin Banas 2012-10-04 10:45:52 EDT
Hello Jesse,

I'm sorry, I forgot to gather the X.log. Since I'm not able to reproduce it today, that means I can't get you the X.log, feel free to close this one.

I'll reopen it if I see it again and manage to gather X.log.

Note You need to log in before you can comment on or make changes to this bug.