Bug 862653 - kickstart installation asks for UI mode
kickstart installation asks for UI mode
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-03 08:04 EDT by Jan Stodola
Modified: 2013-03-12 10:25 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-02 09:41:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda.log (493 bytes, text/plain)
2012-10-03 08:05 EDT, Jan Stodola
no flags Details
program.log (996 bytes, text/plain)
2012-10-03 08:05 EDT, Jan Stodola
no flags Details
storage.log (5.27 KB, text/plain)
2012-10-03 08:06 EDT, Jan Stodola
no flags Details
ks.cfg (186 bytes, text/plain)
2012-10-03 08:07 EDT, Jan Stodola
no flags Details

  None (edit)
Description Jan Stodola 2012-10-03 08:04:09 EDT
Description of problem:
When running kickstart installation, anaconda waits until user selects vnc or text mode before continuing:

...
Starting installer, one moment...
anaconda 18.11 for Fedora 18-Beta-TC1 (pre-release) started.
================================================================================
================================================================================
VNC

Text mode provides a limited set of installation options. It does not allow you 
to specify your own partitioning layout or package selections. Would you like to
 use VNC mode instead?

 1) Start VNC

 2) Use text mode

  Please make your choice from above ['q' to quit | 'c' to continue]: 2
Starting automated install...
...


According to http://fedoraproject.org/wiki/Anaconda/Kickstart#graphical , graphical mode is the default when no UI mode is specified.

Version-Release number of selected component (if applicable):
anaconda 18.11

How reproducible:
always

Steps to Reproduce:
1. prepare kickstart, do not specify UI mode
2. start installation using prepared kickstart
  
Actual results:
user interaction is required to finish the install

Expected results:
anaconda installs without user interaction, graphical UI mode is used for the install (according to http://fedoraproject.org/wiki/Anaconda/Kickstart#graphical)
Comment 1 Jan Stodola 2012-10-03 08:05:06 EDT
Created attachment 620792 [details]
anaconda.log
Comment 2 Jan Stodola 2012-10-03 08:05:36 EDT
Created attachment 620793 [details]
program.log
Comment 3 Jan Stodola 2012-10-03 08:06:01 EDT
Created attachment 620794 [details]
storage.log
Comment 5 Jan Stodola 2012-10-03 08:07:09 EDT
Created attachment 620796 [details]
ks.cfg
Comment 6 Jan Stodola 2012-10-03 10:45:08 EDT
Hmmm, the reason why anaconda didn't start in graphical mode is that boot command line contained "console=ttyS0,115200". Retested in a KVM guest without specifying "console=..." and installation finished correctly in graphical mode. I'm sorry for the confusion on this.


Anyway, when installing with "console=ttyS0,..." command line boot parameter and without any UI options, anaconda should install in text mode.

See http://wwoods.fedorapeople.org/doc/boot-options.html#console about "console" parameter:
This is a kernel option that specifies what device to use as the primary console.
...
Using this option implies text.


This is also how anaconda in RHEL-6 works - switch to text mode without asking to use vnc.
Comment 7 Jesse Keating 2012-10-03 12:02:01 EDT
Hrm, your kickstart doesn't have a preference listed for display mode, no "graphical" or "text" or "vnc" or even "cmdline".  Without a choice there, we don't know what your intention is.  That's why you were prompted.  console= description is a tad misleading.  It starts the install over the specified console, but can still lead to a VNC install.

If you put one of "cmdline" or "text" in your kickstart does it work as intended?
Comment 8 Jan Stodola 2012-10-04 08:17:46 EDT
Well, if using "console=..." implies text (as stated on the page from comment 6), anaconda should use text mode automatically when no UI is scpecified.

If using "console=..." does not imply text and UI mode has to be specified, then documentation needs updating not to confuse users.

The problem is that anaconda behaviour and documentation of boot options differ.

(In reply to comment #7)
> If you put one of "cmdline" or "text" in your kickstart does it work as
> intended?

Yes, it works fine.
Comment 9 Jesse Keating 2012-10-04 13:10:54 EDT
Ah sorry, didn't notice you were looking at wwoods' draft docs.  I'll work with wwoods to update those to reflect current reality.
Comment 10 Jan Stodola 2012-11-02 09:41:30 EDT
Retested with anaconda-18.22, kickstart installation starts in text mode when console=... is specified on kernel command line and no UI mode is specified in kickstart or kernel command line.

Closing this bug.

Note You need to log in before you can comment on or make changes to this bug.