Bug 862753 - Unable to remove provider: promoted repos exist (actually they don't)
Unable to remove provider: promoted repos exist (actually they don't)
Status: CLOSED WORKSFORME
Product: Red Hat Satellite 6
Classification: Red Hat
Component: katello-agent (Show other bugs)
6.0.1
Unspecified Unspecified
medium Severity medium (vote)
: Unspecified
: --
Assigned To: David Davis
Garik Khachikyan
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-03 09:07 EDT by Garik Khachikyan
Modified: 2015-01-04 16:59 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-15 11:44:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Garik Khachikyan 2012-10-03 09:07:49 EDT
Description of problem:
In current version of CFSE 1.1 puddle it is impossible to remove a provider that has repos synced (but *NOT* promoted). CLI complains:
---
Provider cannot be deleted since one of its products or repositories has already been promoted. Using a changeset, please delete the repository from existing environments before deleting it.
---

Version-Release number of selected component (if applicable):
katello-1.1.12-12.el6cf.noarch
katello-cli-1.1.8-6.el6cf.noarch
(puddle: 2012-10-02.2)

How reproducible:
always

Steps to Reproduce:
through CLI:
1.create provider, product, add 2 repos
2.sync that repos
3.try to remove provider
  
Actual results:
error above

Expected results:
no issues. Provider should get removed. proper way of handling checks on repos being promoted.

Additional info:
it's a regression
Comment 2 David Davis 2012-10-15 10:06:44 EDT
So this worked for me on master. Here's what I ran:

katello provider create --org=ACME_Corporation --name=bz
katello product create --org=ACME_Corporation --provider=bz --name=zoo
katello repo create --product=zoo --org=ACME_Corporation --url=http://mmccune.fedorapeople.org/discovery/zoo/ --name=zoo
katello repo create --product=zoo --org=ACME_Corporation --url=http://mmccune.fedorapeople.org/discovery/zoo_ks2/ --name=zoo_ks2
katello repo synchronize --org=ACME_Corporation --product=zoo --name=zoo
katello repo synchronize --org=ACME_Corporation --product=zoo --name=zoo_ks2
katello provider delete --org=ACME_Corporation --name=bz


And the final result:

Deleted provider [ bz ]
Comment 3 David Davis 2012-10-15 10:14:54 EDT
Removing a provider worked in the web UI too.
Comment 6 David Davis 2012-10-15 11:44:51 EDT
Garik, please reopen this if you're able to reproduce with the next puddle. Thanks.
Comment 7 Mike McCune 2013-08-16 14:11:57 EDT
getting rid of 6.0.0 version since that doesn't exist

Note You need to log in before you can comment on or make changes to this bug.