Bug 862790 - gdm first displays a sad face and then displays login screen
gdm first displays a sad face and then displays login screen
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F18-accepted/F18FinalFreezeExcept
  Show dependency treegraph
 
Reported: 2012-10-03 10:36 EDT by Kamil Páral
Modified: 2012-10-08 08:22 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-06 08:10:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
messages (369.18 KB, text/plain)
2012-10-03 10:38 EDT, Kamil Páral
no flags Details
:0.log (40.66 KB, text/plain)
2012-10-03 10:38 EDT, Kamil Páral
no flags Details
:0-greeter.log (1.10 KB, text/plain)
2012-10-03 10:38 EDT, Kamil Páral
no flags Details
:0-slave.log (305 bytes, text/plain)
2012-10-03 10:38 EDT, Kamil Páral
no flags Details

  None (edit)
Description Kamil Páral 2012-10-03 10:36:08 EDT
Description of problem:
If I install F18 Beta TC1 (any architecture) from PXE, and reboot, the gdm first displays a sad face and Log Out button. After 5 seconds, it transitions to a standard login screen and I can login. I don't see any other "problems" related with that. But it is a bit confusing, and on slower machines you can see the sad face even longer, probably.

I haven't tried to press Log Out button before the user list screen kicks in.

I have seen this on two different machines, both installed over PXE. If I install using Live image, I don't see any sad face, gdm works just fine.

Version-Release number of selected component (if applicable):
gdm-3.6.0-1.fc18.x86_64

How reproducible:
always

Steps to Reproduce:
1. install F18 Beta TC1 over PXE
2. boot into gdm
3. see sad face for a while, then user list
Comment 1 Kamil Páral 2012-10-03 10:38:16 EDT
Created attachment 620951 [details]
messages
Comment 2 Kamil Páral 2012-10-03 10:38:19 EDT
Created attachment 620952 [details]
:0.log
Comment 3 Kamil Páral 2012-10-03 10:38:23 EDT
Created attachment 620953 [details]
:0-greeter.log
Comment 4 Kamil Páral 2012-10-03 10:38:26 EDT
Created attachment 620954 [details]
:0-slave.log
Comment 5 Kamil Páral 2012-10-03 10:59:00 EDT
F18 NTH, maybe?
Comment 6 satellitgo 2012-10-03 11:17:07 EDT
also seen in gnome 3.6.0 netinstall to HD i386 . Occurs on restart or reboot also
Comment 7 Kamil Páral 2012-10-03 11:45:13 EDT
enforcing=0 on the boot line fixes this. Reassigning.
Comment 8 Kamil Páral 2012-10-03 11:52:41 EDT
selinux-policy-3.11.1-25.fc18
Comment 9 Kamil Páral 2012-10-04 07:41:58 EDT
I have tracked the problem down to gnome-settings-daemon. gnome-settings-daemon-3.6.0-1 is fine, but gnome-settings-daemon-3.6.0-4 (which also pulls gnome-settings-daemon-updates) causes this bug.

I have no idea whether this is a g-s-d bug or selinux bug.
Comment 10 Miroslav Grepl 2012-10-04 08:03:01 EDT
Kamil,
could you test it with the latest policy build.

-30.fc18
Comment 11 Kamil Páral 2012-10-04 08:23:46 EDT
(In reply to comment #10)
> Kamil,
> could you test it with the latest policy build.
> 
> -30.fc18

Doesn't seem to help.
Comment 12 Miroslav Grepl 2012-10-04 13:43:54 EDT
I apologize, 
try to with the latest build. Thank you.
Comment 13 Kamil Páral 2012-10-04 16:44:02 EDT
-32 fixes it
Comment 14 Kamil Páral 2012-10-08 08:22:34 EDT
Actually we might want to have this ON_QA until the fix is pushed to updates. It seems to be here:
https://admin.fedoraproject.org/updates/FEDORA-2012-15440/selinux-policy-3.11.1-32.fc18

Note You need to log in before you can comment on or make changes to this bug.