Bug 862836 - Changesets: Need to disable +New Changeset button when switching contexts between promotion paths
Changesets: Need to disable +New Changeset button when switching contexts bet...
Status: CLOSED WONTFIX
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: Partha Aji
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-03 13:36 EDT by Corey Welton
Modified: 2014-03-18 13:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-18 13:38:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (21.93 KB, image/png)
2012-10-03 13:38 EDT, Corey Welton
no flags Details

  None (edit)
Description Corey Welton 2012-10-03 13:36:17 EDT
Description of problem:
This has been nagging me for a while but I finally figured it out.

When a user has multiple promotion paths and switches contexts on the Changesets page, s/he can still click the +New Changeset link while the page is going through a context reload. This can often result in the changeset getting created for the wrong path.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:

(note - this is somewhat timing related but it shouldn't be too hard, particularly if you've never visited this page before)

1.  Create a promotion path of Library > Dev > QE
2.  Create a separate promotion  path of Library > Hotfix
3.  Go to Changeset Management > Changesets
4.  Noting that Library > Hotfix is the default path, click the dropdown and choose Library in the "Library > Dev > QE" path
5.  Immediately afterwards, click +New Changeset and create a changeset called "to dev"; save
6. View results
  
Actual results:
The changeset gets saved in the first path
The UI shows one path at the top and a separate environment in the right pane UI (see forthcoming screenshot)

Expected results:
We shouldn't have situations where users can mistakenly create changesets for the wrong environment because the page hasn't loaded yet.  We should probably disable that link while context switching.


Additional info:
It "feels", anyway, like the likelihood of this happening lessens after the user has been on that page for a while, like element caching has made the page render faster and reduced the possibility. But this has happened to me a bunch of times when setting up a newly installed katello instance... it's pretty easy to run into.
Comment 1 Corey Welton 2012-10-03 13:38:57 EDT
Created attachment 621047 [details]
screenshot

note: the changeset created in this instance was different than the steps described in the bug
Comment 4 Mike McCune 2014-03-18 13:38:13 EDT
This bug was closed because of a lack of activity.  If you feel this bug should be reconsidered for attention please feel free to re-open the bug with a comment stating why it should be reconsidered.

Note You need to log in before you can comment on or make changes to this bug.