Bug 862849 - Improve Agent Registration failure message
Improve Agent Registration failure message
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: Agent (Show other bugs)
JON 3.1.1
Unspecified Unspecified
medium Severity low
: ER01
: JON 3.2.0
Assigned To: John Mazzitelli
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-03 14:29 EDT by Charles Crouch
Modified: 2015-02-01 18:28 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-02 15:43:14 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 18941 None None None 2012-10-03 14:29:57 EDT

  None (edit)
Description Charles Crouch 2012-10-03 14:29:18 EDT
Output from the agent when registration fails is currently...

The server has rejected the agent registration request. Cause: [org.rhq.core.clientapi.server.core.AgentRegistrationException:The agent asking for registration is trying to register the same address/port [xx.xx.xxx.xx:16163] that is already registered under a different name [TestAgent]; if this new agent is actually the same as the original, then re-register with the same name]

After discussion with larry the improved text we came up with is a follows

The server has rejected the agent registration request. Cause: [org.rhq.core.clientapi.server.core.AgentRegistrationException:The agent asking for registration is trying to register the same address/port [xx.xx.xxx.xx:16163] that is already registered under a different name [TestAgent]. If this new agent is actually the same as the original, then re-register with the same name. Otherwise you should uninventory the Platform resource for agent [TestAgent] and re-register this new agent.]
Comment 1 Charles Crouch 2012-10-08 09:41:05 EDT
Setting to high priority, since this should be an easy change
Comment 2 John Mazzitelli 2013-03-11 15:01:39 EDT
Looks like the change is simply to add this sentence at the end of the existing message:

"Otherwise you should uninventory the Platform resource for agent [TestAgent] and re-register this new agent."

git commit to master: 5f1be1f
Comment 3 Larry O'Leary 2013-09-06 10:32:34 EDT
As this is MODIFIED or ON_QA, setting milestone to ER1.

Note You need to log in before you can comment on or make changes to this bug.