Bug 8629 - Installer hangs and destroys boot record
Installer hangs and destroys boot record
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-01-19 12:56 EST by Jan J. Nathan
Modified: 2015-01-07 18:40 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-10 11:24:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan J. Nathan 2000-01-19 12:56:53 EST
INTRODUCTION
I have just registered my Red Hat 6.1 (product ID 35b891c24881c6bc).

SUMMARY
Installer hangs after having finished copying the selected packages to the
hard disk. What am I doing wrong?

POSSIBLY RELATED BUGS
5570 Installer hangs during post-installation config
6755 installer puts LILO in MBR even though I told it not to!
6843 Redhat 6.1 Installation Freezage
     (note: I have an Award Modular BIOS v4.51PG. It has a setup
     screen called "PNP/PCI Configuration" with two settings:
     - Resources Controlled By: Auto
     - Reset Configuration Data: Disabled
     I tried setting the second option to Enabled but this had no
     effect. The installer hangs at the same point.

HARDWARE
Pentium 133, 40 MB Ram, one 9 GB IDE disk, one 2 GB SCSI disk, one SCSI
CD-ROM reader, one SCSI CD-ROM burner, one SCSI ZIP drive. All SCSI devices
on AHA-2940UW. Diamond Multimedia Stealth 3D (S3 ViRGE) with 4 MB, Macom
N110 monitor. Soundblaster AWE32. Printer and scanner on parallel port.

WHAT I DID
0. Prepared several Linux Ext2 partitions using PowerQuest PartitionMagic:
three on /dev/hda, one on /dev/sda. Made one swap partition on each disk
(ca. 200 MB on /dev/hda, 64 MB on /dev/sda). Configured BootMagic to allow
booting from /dev/hda1 for Windows 98 or /dev/hda6 for RedHat Linux.
1. Booted from CD-ROM using autoboot.bat (BIOS does not support direct
booting from CD-ROM)
2. Language: English
3. Keyboard: Generic 101-key PC - U.S. English w/ deadkeys - None
4. Mouse: Generic 3 Button Mouse (PS/2)
5. Install Path: custom
### at this point the following error message appeared:
	An error occurred reading the partition table
	for the block device /tmp/sdb. The error was:
	Device nor configured.
### Note: /dev/sdb is the ZIP drive, which I do not need for the
### installation. So I clicked the [Skip Drive]-button.
6. Partitions: mounted / on /dev/hda6
7. Formatted no partitions because /dev/hda6 was already formatted by
PartitionMagic (or so I assumed - worked OK with Slackware Linux)
NOTE: here is one thing I did not try out yet: there were remnants of an
earlier Linux installation on that partition. Can that be related to my
problems? One would say not, because post-install configuration should deal
only with the packages that have just been installed, i.e. overwritten
whatever was in the partition before. But I will try reformatting during
the installation at the earliest opportunity.
8. LILO: deselected option "Create boot disk"; Selected install LILO boot
record on: "/dev/hda6 First sector of boot partition". Removed label "dos"
from /dev/hda1 because I was planning on using BootMagic for that.
9. Time Zone: Europe/Brussels
10. Account configuration: entered root password and created one additional
user
11. Authentication: left preselection of MD5 and shadow unchanged.
12. Package Groups: "Select individual packages" OFF. Selected X Window
System, GNOME, KDE, Mail/WWW/News Tools, DOS/Windows Connectivity, Graphics
Manipulation, Games, Multimedia Support, Dialup Workstation, Extra
Documentation, Utilities
13. X configuration:
a) monitor was not autodetected, I selected Generic Multisync
b) when I tried the second time, now having booted from the boot floppy,
monitor type "Plug and Play Monitor"
In both cases I selected the options "Customize X Configuration" and "Use
Graphical Login". Configuration test worked OK.
14. Configuration Customization: selected all available modes and depths up
to 1024x768
15. Installation of the packages commenced, look OK.

THE RESULT
After all packages had been installed, the message "Performing post install
configuration" appeared. Then... nothing. Total hangup. Only hard reset
worked. After that, the letters "LI" appeared, and another hang. To me
indicates that the installer had attempted to install LILO in the MBR,
against my instructions. I had to use the BootMagic rescue disk to get the
system up and running again, but my Red Hat installation was useless.

ADDITIONAL COMMENTS
These are not bugs, just suggestions for improvement.
1) In X Configuration screen, include an option to allow for direct entry
of monitor specifications to define your own type
2) in X Customization, allow user to go back to previous screen and modify
monitor selection (now you can go back but you can no longer select a
monitor type)
3) Fix total time estimate during package installation: estimate started at
295 hours and ended up at 38 minutes.

Jan J. Nathan
Riemst, Belgium
jan.nathan@ping.be
Comment 1 Jay Turner 2000-02-10 11:24:59 EST
This issue has been resolved in the latest installer.  Thanks for the detailed
bug report . . . really helps when trying to replicate the situation.

As for the suggestions, you will find that all of them are already implemented
in the latest installer (available in the beta!)
Comment 2 jsalacup 2000-02-24 22:05:59 EST
I got the same problem so where can we get that new installer? Is it already
available and how can we get it? Please help. I've been trying to install this
6.1 and my phone installation support is expiring on Feb. 24 but still
unsuccessful. Thanks in advance.

Note You need to log in before you can comment on or make changes to this bug.