Bug 862926 - [abrt] irqbalance-1.0.3-6.fc17: g_list_first: Process /usr/sbin/irqbalance was killed by signal 11 (SIGSEGV)
[abrt] irqbalance-1.0.3-6.fc17: g_list_first: Process /usr/sbin/irqbalance wa...
Status: CLOSED DUPLICATE of bug 859572
Product: Fedora
Classification: Fedora
Component: irqbalance (Show other bugs)
17
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Petr Holasek
Fedora Extras Quality Assurance
abrt_hash:a511ee20ea6aa97506e89e4c6eb...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-03 18:40 EDT by Orion Caspar
Modified: 2016-10-04 00:08 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-21 11:57:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: core_backtrace (681 bytes, text/plain)
2012-10-03 18:40 EDT, Orion Caspar
no flags Details
File: environ (144 bytes, text/plain)
2012-10-03 18:40 EDT, Orion Caspar
no flags Details
File: limits (1.29 KB, text/plain)
2012-10-03 18:40 EDT, Orion Caspar
no flags Details
File: cgroup (166 bytes, text/plain)
2012-10-03 18:40 EDT, Orion Caspar
no flags Details
File: maps (2.26 KB, text/plain)
2012-10-03 18:40 EDT, Orion Caspar
no flags Details
File: dso_list (706 bytes, text/plain)
2012-10-03 18:40 EDT, Orion Caspar
no flags Details
File: var_log_messages (503 bytes, text/plain)
2012-10-03 18:40 EDT, Orion Caspar
no flags Details
File: open_fds (87 bytes, text/plain)
2012-10-03 18:40 EDT, Orion Caspar
no flags Details

  None (edit)
Description Orion Caspar 2012-10-03 18:40:18 EDT
Version-Release number of selected component:
irqbalance-1.0.3-6.fc17

Additional info:
libreport version: 2.0.14
abrt_version:   2.0.13
backtrace_rating: 4
cmdline:        /usr/sbin/irqbalance
crash_function: g_list_first
kernel:         3.5.4-2.fc17.i686.PAE

backtrace:
:[New LWP 581]
:[Thread debugging using libthread_db enabled]
:Using host libthread_db library "/lib/libthread_db.so.1".
:Core was generated by `/usr/sbin/irqbalance'.
:Program terminated with signal 11, Segmentation fault.
:#0  g_list_first (list=0x101) at glist.c:840
:840	      while (list->prev)
:
:Thread 1 (Thread 0xb776c700 (LWP 581)):
:#0  g_list_first (list=0x101) at glist.c:840
:No locals.
:#1  0x0804aeb4 in for_each_irq (list=0x101, cb=cb@entry=0x804b0a0 <clear_irq_stats>, data=data@entry=0x0) at classify.c:365
:        entry = <optimized out>
:        next = <optimized out>
:#2  0x0804b2f9 in clear_obj_stats (d=0x82b95e0, data=data@entry=0x0) at cputree.c:319
:No locals.
:#3  0x0804b2d5 in for_each_object (data=0x0, cb=0x804b2a0 <clear_obj_stats>, list=<optimized out>) at irqbalance.h:124
:        entry = <optimized out>
:        next = 0x82b8370
:#4  clear_obj_stats (d=0x82bf880, data=data@entry=0x0) at cputree.c:318
:No locals.
:#5  0x0804b2d5 in for_each_object (data=0x0, cb=0x804b2a0 <clear_obj_stats>, list=<optimized out>) at irqbalance.h:124
:        entry = <optimized out>
:        next = 0x82b7340
:#6  clear_obj_stats (d=0x80511c0, data=data@entry=0x0) at cputree.c:318
:No locals.
:#7  0x0804b475 in for_each_object (data=0x0, cb=0x804b2a0 <clear_obj_stats>, list=<optimized out>) at irqbalance.h:124
:        entry = <optimized out>
:        next = 0x0
:#8  clear_work_stats () at cputree.c:329
:No locals.
:#9  0x0804941c in main (argc=1, argv=0xbfcab294) at irqbalance.c:291
:        action = {__sigaction_handler = {sa_handler = 0x804bf20 <handler>, sa_sigaction = 0x804bf20 <handler>}, sa_mask = {__val = {0 <repeats 32 times>}}, sa_flags = 0, sa_restorer = 0x4bd8df5d <__cxa_atexit+29>}
:From        To          Syms Read   Shared Object Library
:0x4c348e20  0x4c34aac4  Yes         /lib/libcap-ng.so.0
:0x4bff5c50  0x4c095b24  Yes         /lib/libglib-2.0.so.0
:0x4bf37470  0x4bf51678  Yes         /lib/libm.so.6
:0x4c33ee90  0x4c342f04  Yes         /lib/libnuma.so.1
:0x4bd72f20  0x4beb302c  Yes         /lib/libc.so.6
:0x4bd39850  0x4bd51ec7  Yes         /lib/ld-linux.so.2
:0x4bf1b6a0  0x4bf26e60  Yes         /lib/libpthread.so.0
:0x4bf61920  0x4bf6545c  Yes         /lib/librt.so.1
:$1 = 0x0
:$2 = 0x0
:eax            0x101	257
:ecx            0x0	0
:edx            0x0	0
:ebx            0x82b8370	137069424
:esp            0xbfcab07c	0xbfcab07c
:ebp            0xbfcab1f8	0xbfcab1f8
:esi            0x0	0
:edi            0x804b0a0	134525088
:eip            0x4c024fd2	0x4c024fd2 <g_list_first+18>
:eflags         0x10202	[ IF RF ]
:cs             0x73	115
:ss             0x7b	123
:ds             0x7b	123
:es             0x7b	123
:fs             0x0	0
:gs             0x33	51
:Dump of assembler code for function g_list_first:
:   0x4c024fc0 <+0>:	mov    0x4(%esp),%eax
:   0x4c024fc4 <+4>:	test   %eax,%eax
:   0x4c024fc6 <+6>:	jne    0x4c024fd2 <g_list_first+18>
:   0x4c024fc8 <+8>:	jmp    0x4c024fda <g_list_first+26>
:   0x4c024fca <+10>:	lea    0x0(%esi),%esi
:   0x4c024fd0 <+16>:	lea    (%edx),%eax
:=> 0x4c024fd2 <+18>:	mov    0x8(%eax),%edx
:   0x4c024fd5 <+21>:	test   %edx,%edx
:   0x4c024fd7 <+23>:	jne    0x4c024fd0 <g_list_first+16>
:   0x4c024fd9 <+25>:	ret    
:   0x4c024fda <+26>:	ret    
:End of assembler dump.
Comment 1 Orion Caspar 2012-10-03 18:40:22 EDT
Created attachment 621191 [details]
File: core_backtrace
Comment 2 Orion Caspar 2012-10-03 18:40:25 EDT
Created attachment 621192 [details]
File: environ
Comment 3 Orion Caspar 2012-10-03 18:40:27 EDT
Created attachment 621193 [details]
File: limits
Comment 4 Orion Caspar 2012-10-03 18:40:30 EDT
Created attachment 621194 [details]
File: cgroup
Comment 5 Orion Caspar 2012-10-03 18:40:33 EDT
Created attachment 621195 [details]
File: maps
Comment 6 Orion Caspar 2012-10-03 18:40:35 EDT
Created attachment 621196 [details]
File: dso_list
Comment 7 Orion Caspar 2012-10-03 18:40:38 EDT
Created attachment 621197 [details]
File: var_log_messages
Comment 8 Orion Caspar 2012-10-03 18:40:40 EDT
Created attachment 621198 [details]
File: open_fds
Comment 9 Petr Holasek 2013-01-21 11:57:10 EST

*** This bug has been marked as a duplicate of bug 859572 ***

Note You need to log in before you can comment on or make changes to this bug.