Bug 86293 - (USB)very good example from a forum of the issue.
(USB)very good example from a forum of the issue.
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
8.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Pete Zaitcev
Brian Brock
http://www.linuxquestions.org/questio...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-03-18 20:48 EST by Need Real Name
Modified: 2007-04-18 12:52 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-05 14:55:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2003-03-18 20:48:49 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.2) Gecko/20030208
Netscape/7.02

Description of problem:
A Toshiba Tecra 9100 laptop will hang while intializing USB after a reboot on a
Redhat 8.0 full install, even when fully patched.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install Redhat 8.0 full install on Toshiba Tecra 9100.
2.Reboot.
3.It hangs initializing USB and you will have to cut the power.  Inpropper
system shutdown required which is serious.
    

Additional info:
Comment 1 Larry Troan 2003-03-28 17:24:00 EST
Per my conversation with the originator, we need the following information in
order to troubleshoot this laptop problem. Please append it to this bugzilla.

uname -a > kernel level
("latest patches" is not adequate information since this changes often)
lspci -vv > lspci.vv  
lspci -n > lspci.n 
lsmod > lsmod.out
cat /var/log/messages > messages
cat /var/log/dmesg > dmesg

This will give Engineering an understanding of your box but is not a guarantee
that we can fix it so our code is compatible with it. Many laptops use special
chips to save power that cause problems. Though this happens most often with
video chips, it can also be a problem with other functions such as USB2, sound,
NICs, onboard modems, firewire and wireless. Recently, with the extreme
competitiveness of hardware pricing, some vendors have been using really cheap
CD-ROMS that we can't get to work with Linux. I've also seen some systems run OK
under windows but die under the more demanding requirements LInux can put on
their junk hardware. 

The best way to insure that the machine you have is compatible with Red Hat
Linux is to look on the Red Hat web site for the hardware compatibility list
(search on hcl). Many of our major partners either certify their hardware and
have Red Hat post the results, or they pay Red Hat to certify their hardware.
Though this process focuses on servers there are some workstations, desktops and
laptops certified on this site. The "compatible" list offers people a chance to
list their favorite NICs and other adapters.

The other thing that can complicate matters is that vendors sometimes tweak
their chips during their life cycle and assign new revision codes which are
detected with the above lspci commands. Sometimes these "tweaks" make a once
valid certification become invalid.  

Doing a google search (www.google.com/linux) on the Internet can also be quite
helpful. Use your labtop model as a search argument and see what turns up. When
I bought my first laptop several years ago, I had to search the Internet for a
video driver and download it from a French website with its French docs to get
the laptop working. It's a good thing I studied French in high school otherwise
the instructions would have been impossible to understand. 

Red Hat can not guarantee that every piece of hardware will be supported by RH
Linux. Vendors will always test with the latest version of Windows because they
know if it doesn't run that propretary OS, they won't be able to sell their
hardware but many are only beginning to see the light and test their hardware on
Linux.
Comment 2 Larry Troan 2003-03-28 17:29:03 EST
Note also that Red Hat does not have the time to solicite information from
vendors regarding specific hardware nor to we buy such hardware to test it.
Several of our partners loan us the equipment they feel their customers will
purchase and want to run Linux on. You might want to write your laptop
manufacturer and ask them if they plan to certify it for use with Linux. They
might begin to see the light.... 
Comment 3 Arjan van de Ven 2003-03-30 08:23:00 EST
there is a "nousb" kernel option (type "a" in grub to add it) that should
disable any usb use so that it becomes possible to diagnose this further

Note You need to log in before you can comment on or make changes to this bug.