Bug 862944 - SELinux is preventing /usr/bin/python2.7 from 'getattr' accesses on the file /var/lib/up2date/dbtimestamp.
SELinux is preventing /usr/bin/python2.7 from 'getattr' accesses on the file ...
Status: CLOSED DUPLICATE of bug 862943
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:2dfa5b755dd8a1f51964046d51e...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-03 21:42 EDT by Maurice James
Modified: 2012-10-04 03:59 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-04 03:59:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: type (9 bytes, text/plain)
2012-10-03 21:42 EDT, Maurice James
no flags Details
File: hashmarkername (14 bytes, text/plain)
2012-10-03 21:42 EDT, Maurice James
no flags Details

  None (edit)
Description Maurice James 2012-10-03 21:42:46 EDT
Additional info:
libreport version: 2.0.14
kernel:         3.5.4-1.fc17.x86_64

description:
:SELinux is preventing /usr/bin/python2.7 from 'getattr' accesses on the file /var/lib/up2date/dbtimestamp.
:
:*****  Plugin catchall_labels (83.8 confidence) suggests  ********************
:
:If you want to allow python2.7 to have getattr access on the dbtimestamp file
:Then you need to change the label on /var/lib/up2date/dbtimestamp
:Do
:# semanage fcontext -a -t FILE_TYPE '/var/lib/up2date/dbtimestamp'
:where FILE_TYPE is one of the following: rpm_exec_t, rpm_var_cache_t, textrel_shlib_t, user_home_t, proc_net_t, rhsmcertd_var_lib_t, rhsmcertd_var_run_t, rpm_script_tmp_t, ld_so_cache_t, rpm_var_lib_t, abrt_var_cache_t, net_conf_t, puppet_tmp_t, sosreport_tmp_t, machineid_t, fail2ban_var_lib_t, rpm_tmp_t, abrt_var_run_t, sysctl_crypto_t, rhsmcertd_t, cfengine_var_log_t, locale_t, var_lock_t, etc_t, bin_t, cert_t, proc_t, user_cron_spool_t, usr_t, rhsmcertd_log_t, abrt_t, ld_so_t, lib_t, user_tmp_t, cpu_online_t, passwd_file_t, abrt_helper_exec_t, logfile, rhsmcertd_exec_t, rhsmcertd_lock_t, root_t. 
:Then execute: 
:restorecon -v '/var/lib/up2date/dbtimestamp'
:
:
:*****  Plugin catchall (17.1 confidence) suggests  ***************************
:
:If you believe that python2.7 should be allowed getattr access on the dbtimestamp file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep rhn_check /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:rhsmcertd_t:s0
:Target Context                unconfined_u:object_r:var_lib_t:s0
:Target Objects                /var/lib/up2date/dbtimestamp [ file ]
:Source                        rhn_check
:Source Path                   /usr/bin/python2.7
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           python-2.7.3-7.2.fc17.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-150.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.5.4-1.fc17.x86_64 #1 SMP Mon Sep
:                              17 15:03:59 UTC 2012 x86_64 x86_64
:Alert Count                   1
:First Seen                    2012-10-03 21:40:18 EDT
:Last Seen                     2012-10-03 21:40:18 EDT
:Local ID                      7b217f65-7328-41e4-a8f8-dbdef13a66fa
:
:Raw Audit Messages
:type=AVC msg=audit(1349314818.83:6037): avc:  denied  { getattr } for  pid=24393 comm="rhn_check" path="/var/lib/up2date/dbtimestamp" dev="dm-1" ino=3146019 scontext=system_u:system_r:rhsmcertd_t:s0 tcontext=unconfined_u:object_r:var_lib_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1349314818.83:6037): arch=x86_64 syscall=stat success=no exit=EACCES a0=1319a60 a1=7fff627f8b10 a2=7fff627f8b10 a3=20 items=0 ppid=828 pid=24393 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=rhn_check exe=/usr/bin/python2.7 subj=system_u:system_r:rhsmcertd_t:s0 key=(null)
:
:Hash: rhn_check,rhsmcertd_t,var_lib_t,file,getattr
:
:audit2allow
:
:#============= rhsmcertd_t ==============
:allow rhsmcertd_t var_lib_t:file getattr;
:
:audit2allow -R
:
:#============= rhsmcertd_t ==============
:allow rhsmcertd_t var_lib_t:file getattr;
:
Comment 1 Maurice James 2012-10-03 21:42:50 EDT
Created attachment 621226 [details]
File: type
Comment 2 Maurice James 2012-10-03 21:42:51 EDT
Created attachment 621227 [details]
File: hashmarkername
Comment 3 Miroslav Grepl 2012-10-04 03:59:43 EDT

*** This bug has been marked as a duplicate of bug 862943 ***

Note You need to log in before you can comment on or make changes to this bug.