Bug 862945 - SELinux is preventing /usr/bin/python2.7 from 'write' accesses on the directory /var/lib/yum/yumdb.
SELinux is preventing /usr/bin/python2.7 from 'write' accesses on the directo...
Status: CLOSED DUPLICATE of bug 862943
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:71e083cfaabc8b898fb3a3b0d27...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-03 21:43 EDT by Maurice James
Modified: 2012-10-04 03:59 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-04 03:59:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: type (9 bytes, text/plain)
2012-10-03 21:43 EDT, Maurice James
no flags Details
File: hashmarkername (14 bytes, text/plain)
2012-10-03 21:43 EDT, Maurice James
no flags Details

  None (edit)
Description Maurice James 2012-10-03 21:43:25 EDT
Additional info:
libreport version: 2.0.14
kernel:         3.5.4-1.fc17.x86_64

description:
:SELinux is preventing /usr/bin/python2.7 from 'write' accesses on the directory /var/lib/yum/yumdb.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that python2.7 should be allowed write access on the yumdb directory by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep rhn_check /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:rhsmcertd_t:s0
:Target Context                system_u:object_r:rpm_var_lib_t:s0
:Target Objects                /var/lib/yum/yumdb [ dir ]
:Source                        rhn_check
:Source Path                   /usr/bin/python2.7
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           python-2.7.3-7.2.fc17.x86_64
:Target RPM Packages           yum-3.4.3-29.fc17.noarch
:Policy RPM                    selinux-policy-3.10.0-150.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.5.4-1.fc17.x86_64 #1 SMP Mon Sep
:                              17 15:03:59 UTC 2012 x86_64 x86_64
:Alert Count                   1
:First Seen                    2012-10-03 21:40:17 EDT
:Last Seen                     2012-10-03 21:40:17 EDT
:Local ID                      c1912a28-b018-420d-b948-db59b5942a93
:
:Raw Audit Messages
:type=AVC msg=audit(1349314817.506:6036): avc:  denied  { write } for  pid=24393 comm="rhn_check" name="yumdb" dev="dm-1" ino=3145744 scontext=system_u:system_r:rhsmcertd_t:s0 tcontext=system_u:object_r:rpm_var_lib_t:s0 tclass=dir
:
:
:type=SYSCALL msg=audit(1349314817.506:6036): arch=x86_64 syscall=access success=no exit=EACCES a0=e88180 a1=2 a2=3b2a1b39c8 a3=20 items=0 ppid=828 pid=24393 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=rhn_check exe=/usr/bin/python2.7 subj=system_u:system_r:rhsmcertd_t:s0 key=(null)
:
:Hash: rhn_check,rhsmcertd_t,rpm_var_lib_t,dir,write
:
:audit2allow
:
:#============= rhsmcertd_t ==============
:#!!!! The source type 'rhsmcertd_t' can write to a 'dir' of the following types:
:# rhsmcertd_var_lib_t, rhsmcertd_var_run_t, var_run_t, var_lock_t, rhsmcertd_log_t, rhsmcertd_lock_t, root_t
:
:allow rhsmcertd_t rpm_var_lib_t:dir write;
:
:audit2allow -R
:
:#============= rhsmcertd_t ==============
:#!!!! The source type 'rhsmcertd_t' can write to a 'dir' of the following types:
:# rhsmcertd_var_lib_t, rhsmcertd_var_run_t, var_run_t, var_lock_t, rhsmcertd_log_t, rhsmcertd_lock_t, root_t
:
:allow rhsmcertd_t rpm_var_lib_t:dir write;
:
Comment 1 Maurice James 2012-10-03 21:43:27 EDT
Created attachment 621228 [details]
File: type
Comment 2 Maurice James 2012-10-03 21:43:29 EDT
Created attachment 621229 [details]
File: hashmarkername
Comment 3 Miroslav Grepl 2012-10-04 03:59:50 EDT

*** This bug has been marked as a duplicate of bug 862943 ***

Note You need to log in before you can comment on or make changes to this bug.