Bug 862956 - SELinux is preventing /usr/bin/grep from 'ioctl' accesses on the file /usr/lib/systemd/system/cups.service.
SELinux is preventing /usr/bin/grep from 'ioctl' accesses on the file /usr/li...
Status: CLOSED DUPLICATE of bug 862957
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:4a7258aa9f76c6588d56cf9aa50...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-03 22:56 EDT by Tony
Modified: 2012-10-06 08:09 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-06 08:09:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: type (9 bytes, text/plain)
2012-10-03 22:56 EDT, Tony
no flags Details
File: hashmarkername (14 bytes, text/plain)
2012-10-03 22:56 EDT, Tony
no flags Details

  None (edit)
Description Tony 2012-10-03 22:56:48 EDT
Description of problem:
When attempting to print to fax from Libreoffice Write on HP fax / printer C7280.
Happens every time I try to print to fax.


Additional info:
libreport version: 2.0.14
kernel:         3.5.4-2.fc17.x86_64

description:
:SELinux is preventing /usr/bin/grep from 'ioctl' accesses on the file /usr/lib/systemd/system/cups.service.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that grep should be allowed ioctl access on the cups.service file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep grep /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:hplip_t:s0-s0:c0.c1023
:Target Context                system_u:object_r:cupsd_unit_file_t:s0
:Target Objects                /usr/lib/systemd/system/cups.service [ file ]
:Source                        grep
:Source Path                   /usr/bin/grep
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           grep-2.14-1.fc17.x86_64
:Target RPM Packages           cups-1.5.4-2.fc17.x86_64
:Policy RPM                    selinux-policy-3.10.0-149.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Permissive
:Host Name                     (removed)
:Platform                      Linux (removed) 3.5.4-2.fc17.x86_64 #1 SMP Wed Sep
:                              26 21:58:50 UTC 2012 x86_64 x86_64
:Alert Count                   1
:First Seen                    2012-10-04 15:14:49 NZDT
:Last Seen                     2012-10-04 15:14:49 NZDT
:Local ID                      f9590d06-c373-4def-899a-d05fb2c7ea98
:
:Raw Audit Messages
:type=AVC msg=audit(1349316889.6:102): avc:  denied  { ioctl } for  pid=2117 comm="grep" path="/usr/lib/systemd/system/cups.service" dev="sda5" ino=414624 scontext=system_u:system_r:hplip_t:s0-s0:c0.c1023 tcontext=system_u:object_r:cupsd_unit_file_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1349316889.6:102): arch=x86_64 syscall=ioctl success=no exit=ENOTTY a0=3 a1=5401 a2=7fff82c31cb0 a3=0 items=0 ppid=2113 pid=2117 auid=4294967295 uid=0 gid=7 euid=0 suid=0 fsuid=0 egid=7 sgid=7 fsgid=7 tty=pts0 ses=4294967295 comm=grep exe=/usr/bin/grep subj=system_u:system_r:hplip_t:s0-s0:c0.c1023 key=(null)
:
:Hash: grep,hplip_t,cupsd_unit_file_t,file,ioctl
:
:audit2allow
:
:#============= hplip_t ==============
:allow hplip_t cupsd_unit_file_t:file ioctl;
:
:audit2allow -R
:
:#============= hplip_t ==============
:allow hplip_t cupsd_unit_file_t:file ioctl;
:
Comment 1 Tony 2012-10-03 22:56:51 EDT
Created attachment 621281 [details]
File: type
Comment 2 Tony 2012-10-03 22:56:53 EDT
Created attachment 621282 [details]
File: hashmarkername
Comment 3 Daniel Walsh 2012-10-06 08:09:02 EDT

*** This bug has been marked as a duplicate of bug 862957 ***

Note You need to log in before you can comment on or make changes to this bug.