This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 862958 - SELinux is preventing /usr/bin/python2.7 from 'open' accesses on the chr_file /dev/pts/0.
SELinux is preventing /usr/bin/python2.7 from 'open' accesses on the chr_file...
Status: CLOSED DUPLICATE of bug 862961
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:a9dc90f1970faaac6e0dc71f4ff...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-03 22:58 EDT by Tony
Modified: 2012-10-06 08:03 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-06 08:03:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: type (9 bytes, text/plain)
2012-10-03 22:58 EDT, Tony
no flags Details
File: hashmarkername (14 bytes, text/plain)
2012-10-03 22:58 EDT, Tony
no flags Details

  None (edit)
Description Tony 2012-10-03 22:58:54 EDT
Description of problem:
When attempting to print to fax from Libreoffice Write on HP fax / printer C7280.
Happens every time I try to print to fax.


Additional info:
libreport version: 2.0.14
kernel:         3.5.4-2.fc17.x86_64

description:
:SELinux is preventing /usr/bin/python2.7 from 'open' accesses on the chr_file /dev/pts/0.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that python2.7 should be allowed open access on the 0 chr_file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep hpfax /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:hplip_t:s0-s0:c0.c1023
:Target Context                system_u:object_r:devpts_t:s0
:Target Objects                /dev/pts/0 [ chr_file ]
:Source                        hpfax
:Source Path                   /usr/bin/python2.7
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           python-2.7.3-7.2.fc17.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-149.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Permissive
:Host Name                     (removed)
:Platform                      Linux (removed) 3.5.4-2.fc17.x86_64 #1 SMP Wed Sep
:                              26 21:58:50 UTC 2012 x86_64 x86_64
:Alert Count                   1
:First Seen                    2012-10-04 15:14:48 NZDT
:Last Seen                     2012-10-04 15:14:48 NZDT
:Local ID                      4c5e0a19-ab5b-4014-89b0-11bbfa9e63e0
:
:Raw Audit Messages
:type=AVC msg=audit(1349316888.993:100): avc:  denied  { open } for  pid=2113 comm="hpfax" path="/dev/pts/0" dev="devpts" ino=3 scontext=system_u:system_r:hplip_t:s0-s0:c0.c1023 tcontext=system_u:object_r:devpts_t:s0 tclass=chr_file
:
:
:type=SYSCALL msg=audit(1349316888.993:100): arch=x86_64 syscall=open success=yes exit=ENOEXEC a0=7fffb40caba0 a1=102 a2=ff6 a3=0 items=0 ppid=698 pid=2113 auid=4294967295 uid=0 gid=7 euid=0 suid=0 fsuid=0 egid=7 sgid=7 fsgid=7 tty=(none) ses=4294967295 comm=hpfax exe=/usr/bin/python2.7 subj=system_u:system_r:hplip_t:s0-s0:c0.c1023 key=(null)
:
:Hash: hpfax,hplip_t,devpts_t,chr_file,open
:
:audit2allow
:
:#============= hplip_t ==============
:#!!!! This avc can be allowed using the boolean 'allow_daemons_use_tty'
:
:allow hplip_t devpts_t:chr_file open;
:
:audit2allow -R
:
:#============= hplip_t ==============
:#!!!! This avc can be allowed using the boolean 'allow_daemons_use_tty'
:
:allow hplip_t devpts_t:chr_file open;
:
Comment 1 Tony 2012-10-03 22:58:56 EDT
Created attachment 621285 [details]
File: type
Comment 2 Tony 2012-10-03 22:58:58 EDT
Created attachment 621286 [details]
File: hashmarkername
Comment 3 Daniel Walsh 2012-10-06 08:03:18 EDT

*** This bug has been marked as a duplicate of bug 862961 ***

Note You need to log in before you can comment on or make changes to this bug.