Bug 86299 - mp3 explanation dialogue should be modal
mp3 explanation dialogue should be modal
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: xmms (Show other bugs)
9
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Colin Walters
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-03-19 01:34 EST by Kjetil T. Homme
Modified: 2007-04-18 12:52 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-27 15:37:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Kjetil T. Homme 2003-03-19 01:34:26 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030206

Description of problem:
if I try to play an MP3 file, I get a window explaining why MP3 isn't included
in Red Hat.  in this window, there is a check box for "do not tell me again"
which is ON by default.  if you try to turn it off, you'll get another window. 
and so on.


Version-Release number of selected component (if applicable):
xmms-1.2.7-19.p

How reproducible:
Didn't try

Steps to Reproduce:
1.select an MP3 file
2.click check box

(it's a bit hard to reproduce, since the bug makes it impossible to ask xmms to
keep bugging you about this.  I didn't bother to delete my xmms configuration
file to test.)


Actual Results:  a new window pops up.

Expected Results:  the check box should be deselected.

Additional info:
Comment 1 Warren Togami 2003-03-20 16:52:51 EST
This happens once per MP3 in your playlist, problematic if you have hundreds in
your playlist. The entire system crawled for several minutes back in Phoebe1
when this happened.
Comment 2 Bill Nottingham 2003-03-20 16:56:03 EST
As expected... it will pop up once for every attempt to open an mp3 unless you
disable it.
Comment 3 Kjetil T. Homme 2003-03-21 08:00:37 EST
Warren's comment is related, but a different issue from the bug.  you closed it
on the wrong grounds.  the bug is that it is impossible not to disable it, and
in the attempt to not disable it, a new popup will appear for each attempt.

anyway, I think it is a bit arrogant to say that it is expected behaviour when a
user experiences an application bringing his computer to a crawl for no good
reason.  this is actually one case where a modal dialogue makes sense.  xmms
should not progress to the next file in the playlist until the user as
acknowledged the explanation.  if the user selects "please bug me again" (which
doesn't work, which is what _this_ bug is all about), he will get another popup,
but of course, the user explicitly asked for it in that case.
Comment 4 Colin Walters 2004-09-27 15:37:16 EDT
I can't reproduce this.  I created a playlist with a number of MP3s,
hit play, and only got one dialog.  Please reopen if you still have a
problem.

Note You need to log in before you can comment on or make changes to this bug.