Bug 863022 - "Cannot run VM. Not enough resources, contact your System Administrator"
"Cannot run VM. Not enough resources, contact your System Administrator"
Status: CLOSED DUPLICATE of bug 855776
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.0.7
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Roy Golan
Pavel Stehlik
virt
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-04 04:52 EDT by Toni Willberg
Modified: 2012-10-18 06:48 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-18 06:48:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Toni Willberg 2012-10-04 04:52:40 EDT
Description of problem:

 1) I don't know what causes the problem
 2) The error message in the UI doesn't tell what is wrong. Asking the administrator to contact an administrator is useless.

Version-Release number of selected component (if applicable):

 rhevm-webadmin-portal-3.0.7_0001-2-el6_3.x86_64

How reproducible:

 Always (in my setup)


Steps to Reproduce:
1. after installation of RHEV-M and RHEV-H, and creating necessary storages etc.
2. create VM, try to do Run Once or Start
3. error message appears and VM doesn't start
  
Actual results:
 "Cannot run VM. Not enough resources, contact your System Administrator"


Expected results:
 1) no error, VM starts
 2) the error message should always tell exactly what's wrong, or even give relevant error code which could be looked up from documentation


Additional info:

I have an ISCSI storage with size 33GB of which 28GB is available. 


I assume this is the relevant piece of rhevm.log:

2012-10-04 11:24:42,428 INFO [org.ovirt.engine.core.vdsbroker.irsbroker.IsValidVDSCommand] (http-0.0.0.0-8443-7) START, IsValidVDSCommand(storagePoolId = 1014f7c6-bf84-11e1-afcf-001e371ee156, ignoreFailoverLimit = false, compatabilityVersion = null), log id: 4df18a3
2012-10-04 11:24:42,443 INFO [org.ovirt.engine.core.vdsbroker.irsbroker.IsValidVDSCommand] (http-0.0.0.0-8443-7) FINISH, IsValidVDSCommand, return: true, log id: 4df18a3
2012-10-04 11:24:42,495 INFO [org.ovirt.engine.core.vdsbroker.IsVmDuringInitiatingVDSCommand] (http-0.0.0.0-8443-7) START, IsVmDuringInitiatingVDSCommand(vmId = b5222a4b-00ae-45c1-91d3-7146184dd87e), log id: 6369dec4
2012-10-04 11:24:42,495 INFO [org.ovirt.engine.core.vdsbroker.IsVmDuringInitiatingVDSCommand] (http-0.0.0.0-8443-7) FINISH, IsVmDuringInitiatingVDSCommand, return: false, log id: 6369dec4
2012-10-04 11:24:42,500 WARN [org.ovirt.engine.core.bll.RunVmCommand] (http-0.0.0.0-8443-7) CanDoAction of action RunVm failed. Reasons:ACTION_TYPE_FAILED_VDS_VM_CLUSTER,VAR__ACTION__RUN,VAR__TYPE__VM
Comment 3 Roy Golan 2012-10-18 06:48:26 EDT

*** This bug has been marked as a duplicate of bug 855776 ***

Note You need to log in before you can comment on or make changes to this bug.