Bug 863024 - `xzgrep -l word filename.xz` fails with "grep: -q: No such file or directory"
`xzgrep -l word filename.xz` fails with "grep: -q: No such file or directory"
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xz (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Pavel Raiskup
qe-baseos-daemons
: EasyFix
Depends On:
Blocks: 947782
  Show dependency treegraph
 
Reported: 2012-10-04 05:10 EDT by Dan Kenigsberg
Modified: 2014-06-19 04:45 EDT (History)
6 users (show)

See Also:
Fixed In Version: xz-4.999.9-0.4.beta.20091007git.el6
Doc Type: Bug Fix
Doc Text:
Prior to this update, running the 'xzgrep -l' command did not work correctly because the source code did not handle the '-q' option appropriately. As a consequence, an error message was displayed. A patch has been applied to handle the 'grep -q' command in the source code correctly. As a result, running the 'xzgrep -l' suppresses normal output and prints file names with a matching line as expected.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-19 04:45:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Kenigsberg 2012-10-04 05:10:43 EDT
Description of problem:
`xzgrep -l` does not work.

Version-Release number of selected component (if applicable):
xz-4.999.9-0.3.beta.20091007git.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. xzgrep -l word *.xz
  
Actual results:
grep: -q: No such file or directory

Expected results:
list of files with "word"

Additional info:
Solved upstream by

http://git.tukaani.org/?p=xz.git;a=commitdiff;h=c7210d9a3fca6f31a57208bfddfc9ab20a2e097a
http://git.tukaani.org/?p=xz.git;a=commitdiff;h=40277998cb9bad564ce4827aff152e6e1c904dfa
Comment 1 RHEL Product and Program Management 2012-10-04 05:29:46 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 2 Jindrich Novy 2013-02-11 01:22:29 EST
This one is fairly easily to be fixed. It's quite annoying bug fixed in upstream.
Comment 3 RHEL Product and Program Management 2013-10-13 20:23:48 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 9 errata-xmlrpc 2014-06-19 04:45:42 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0769.html

Note You need to log in before you can comment on or make changes to this bug.