Bug 863027 - Bad dependencies
Bad dependencies
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: wordpress (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matěj Cepl
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 891717
  Show dependency treegraph
 
Reported: 2012-10-04 05:31 EDT by Remi Collet
Modified: 2013-01-11 20:22 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 891717 (view as bug list)
Environment:
Last Closed: 2012-12-29 14:30:04 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Remi Collet 2012-10-04 05:31:01 EDT
In wordpress.spec

   Requires: php >= 4.1.0, webserver, php-mysql, php-gettext, php-simplepie
   ...
   # Remove bundled php-gettext and link to system copy
   rm -f ${RPM_BUILD_ROOT}%{_datadir}/wordpress/wp-includes/gettext.php

If wordpress really need gettext.php, it should requires php-php-gettext (which is the pure php extension, not the php-gettext which is the standard C extension)

But, at least in 3.4.2, I don't see gettext.php in upstream tarball (seems dropped since 2.9 (see wp-admin/includes/update-core.php, $_old_files)

Could also worth analysing the output of phpci output

$ phpci print --recursive --report extension wordpress
-------------------------------------------------------------------------------
PHP COMPAT INFO EXTENSION SUMMARY
-------------------------------------------------------------------------------
  EXTENSION                                        PECL   VERSION         COUNT
-------------------------------------------------------------------------------
  Core                                             5.4.7  4.0.0            9137
  SPL                                                0.2  5.0.0               5
  SimpleXML                                          0.1  5.0.0               1
  curl                                                    4.0.2             130
  date                                                    4.0.0             364
  dom                                           20031129  5.0.0               6
  enchant                                          1.1.0  5.0.0              12
  ereg                                                    4.0.0  5.3.0       12
  exif                                                    4.0.1               1
  fileinfo                                         1.0.5  4.0.0               1
  filter                                          0.11.0  4.0.0               2
  ftp                                                     4.0.0              72
  gd                                                      4.0.0              57
  gettext                                                 4.0.0              39
  hash                                               1.0  4.0.0               6
  iconv                                                   4.0.5               6
  json                                             1.2.1  5.2.0              36
  libxml                                                  5.0.0               5
  mbstring                                                4.0.6              31
  mysql                                              1.0  4.0.0              60
  openssl                                                 4.0.4               4
  pcre                                                    4.0.0             757
  posix                                           306939  4.0.0               4
  sockets                                                 4.1.0              64
  ssh2                                            0.11.3  4.0.0              11
  standard                                         5.4.7  4.0.0           12721
  tokenizer                                          0.1  4.2.0               3
  xml                                                     4.0.0              89
  xmlreader                                          0.1  5.0.0               1
  zip                                             1.11.0  4.3.0               1
  zlib                                               2.0  4.0.0              30
-------------------------------------------------------------------------------
Comment 1 Matěj Cepl 2012-10-04 15:54:40 EDT
Suggested fix is a part of wordpress-3.5-0.2.beta1 (currently only scratch build for Rawhide; http://koji.fedoraproject.org/koji/taskinfo?taskID=4559553).

Please review and comment.

Also, you seem to be much more experienced in PHP than I am. I mean, if you wrote longer PHP script than

<?php phpinfo(); ?>

than you know more about PHP than I do. Wouldn't you like to use this knowledge to co-maintain (and later perhaps take over) this package?
Comment 2 Remi Collet 2012-10-05 00:25:42 EDT
(In reply to comment #1)
> Wouldn't you like to use this
> knowledge to co-maintain (and later perhaps take over) this package?

co-ownership request done.

I will try to add the useful requires asap.
Comment 3 Fedora Admin XMLRPC Client 2012-10-05 06:56:14 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 4 Matěj Cepl 2012-10-05 09:26:13 EDT
(In reply to comment #2)
> co-ownership request done.
> 
> I will try to add the useful requires asap.

Well, I have ill-consideredly mention wordpress in front of his original owner, and suddenly it's mine :( So, yes, your comaintainership has been approved.
Comment 5 Gwyn Ciesla 2012-10-05 09:32:02 EDT
Sorry, I thought that was what you wanted, since you've been doing all the work before I could get to it anyway. :)
Comment 6 Fedora Update System 2012-12-12 10:30:46 EST
wordpress-3.5-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/wordpress-3.5-1.el6
Comment 7 Fedora Update System 2012-12-12 10:41:35 EST
wordpress-3.5-1.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/wordpress-3.5-1.el5
Comment 8 Fedora Update System 2012-12-12 10:42:29 EST
wordpress-3.5-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/wordpress-3.5-1.fc17
Comment 9 Fedora Update System 2012-12-12 10:43:13 EST
wordpress-3.5-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/wordpress-3.5-1.fc18
Comment 10 Fedora Update System 2012-12-12 15:43:00 EST
Package wordpress-3.5-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing wordpress-3.5-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-20255/wordpress-3.5-1.fc18
then log in and leave karma (feedback).
Comment 11 Fedora Update System 2012-12-29 14:30:06 EST
wordpress-3.5-1.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2012-12-29 14:32:12 EST
wordpress-3.5-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2012-12-30 22:23:00 EST
wordpress-3.5-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 David Summers 2013-01-04 15:02:41 EST
CentOS 5.8 + EPEL + wordpress 3.1.4 working with no dependency issues:

Then:

# yum update
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: mirror.steadfast.net
 * epel: mirror.steadfast.net
 * extras: mirror.steadfast.net
 * updates: mirror.steadfast.net
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package wordpress.noarch 0:3.5-1.el5 set to be updated
--> Processing Dependency: php53 >= 5.2.4 for package: wordpress
--> Processing Dependency: php53-simplepie for package: wordpress
--> Processing Dependency: php-zip for package: wordpress
--> Processing Dependency: php-json for package: wordpress
--> Processing Dependency: php-fileinfo for package: wordpress
--> Processing Dependency: php-enchant for package: wordpress
--> Running transaction check
---> Package php53.x86_64 0:5.3.3-13.el5_8 set to be updated
--> Processing Dependency: php53-cli = 5.3.3-13.el5_8 for package: php53
---> Package php53-common.x86_64 0:5.3.3-13.el5_8 set to be updated
---> Package php53-enchant.x86_64 0:5.3.3-1.el5 set to be updated
--> Processing Dependency: libenchant.so.1()(64bit) for package: php53-enchant
---> Package wordpress.noarch 0:3.5-1.el5 set to be updated
--> Processing Dependency: php53-simplepie for package: wordpress
--> Running transaction check
---> Package enchant.x86_64 1:1.4.2-4.el5.1 set to be updated
---> Package php53-cli.x86_64 0:5.3.3-13.el5_8 set to be updated
---> Package wordpress.noarch 0:3.5-1.el5 set to be updated
--> Processing Dependency: php53-simplepie for package: wordpress
--> Processing Conflict: php53-common conflicts php-common
--> Finished Dependency Resolution
php53-common-5.3.3-13.el5_8.x86_64 from updates has depsolving problems
  --> php53-common conflicts with php-common
wordpress-3.5-1.el5.noarch from epel has depsolving problems
  --> Missing Dependency: php53-simplepie is needed by package wordpress-3.5-1.el5.noarch (epel)
Error: Missing Dependency: php53-simplepie is needed by package wordpress-3.5-1.el5.noarch (epel)
Error: php53-common conflicts with php-common
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest
The program package-cleanup is found in the yum-utils package.


Now I'm getting failed CentOS and EPEL update notices every hour in my mail.

Please advise.

Thanks.
Comment 15 Fedora Update System 2013-01-11 20:22:34 EST
wordpress-3.5-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.