Bug 86303 - Problem(s) installing on Asus A7N266-VM motherboard w/version 8
Problem(s) installing on Asus A7N266-VM motherboard w/version 8
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
8.0
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-03-19 02:56 EST by Need Real Name
Modified: 2007-04-18 12:52 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-29 15:02:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2003-03-19 02:56:03 EST
Description of problem:  Redhat version 8 linux install CD 1 crashes in 
graphics installation mode with Asus A7N266-VM motherboard.

This motherboard has integrated video, sound, and ethernet.

The problem occurs right after the video hardware and monitor are detected...I 
think at the point when the installer tries to start xwindows.  At this point 
the screen goes uniformely gray and will stay that way forever.

The installer detects the graphics hardware as nVidia GeForce 2 MX (generic).  
The board docs list the graphics hardware as nVidia 220D GeForce MX, which is 
not listed as an option in the text install.

I suspect that Redhat 8 is trying to load the wrong video driver for this 
board, and crashes.

I am no linux expert, but I was able to specify "linux text" and complete the 
install, and then boot the install from diskette successfully in text mode.


There is another problem, which is that I can't seem to get the text upgrade 
option to work...it encounters an unexpected error...so let me know if you want 
me to put this in as a separate bug.  I have the dump file for that one.


Version-Release number of selected component (if applicable):  Redhat Linux Ver 
8 install CD 1


How reproducible: Attempt install of Redhat version 8 from CD.


Steps to Reproduce:
1. boot up Redhat linux install CD 1
2. get past blue screen for "media check"
3. installer detects video as "nVidia GeForce 2 MX (generic"
4. installer is not able to detect monitor (Envision is not in Redhat's list, 
seemingly)
5. installer goes down a couple more text lines to a point where it says 
something to the effect of "starting X windows" 
6. at this point screen goes flat gray, CD drive stops 30 secs later, and the 
PC is dead in the water.
    
Actual results:  dead PC moments into install


Expected results:  successful install process from CDs in graphics mode


Additional info:  There are no cards on the PC but the motherboard.  The BIOS 
is pretty much the default values.   WIN2000 was easily and successfully 
installed on this motherboard in exactly the same hardware configuration, but 
it did need the Asus drivers for the integrated hardware. Asus has no drivers 
for linux except source for the sound card.  512 meg of 266 memory.  Athlon 1.5 
ghz processor.
Comment 1 Michael Fulbright 2003-03-20 11:42:17 EST
If you boot with 'linux text' does the installer properly go into text mode?
Comment 2 Need Real Name 2003-03-20 17:07:49 EST
yes...the option "linux text" allowed me to install 
Redhat, although there were a couple of glitches, 
I managed to complete the install.

However, I still can't do a "startx" as the 
graphics system is not set up....it's a catch 22, 
as I need to install in graphical mode to have 
Redhat set up graphical mode.

I tried other options to install in graphical mode, 
such as "noprobe", but Redhat unilaterally 
insisted on loading the monitor driver it 
selected, and starting up x windows...leading to 
a crash every time. 
Comment 3 Michael Fulbright 2003-03-21 11:02:10 EST
If you install with 'linux text' and make sure to install the X Windows system
(do a Personal Desktop install, for example).  Then when you reboot X probably
doesn't work.  Then you can login as root on a console and run
'redhat-config-xfree86'.  If this tool does not configure your system properly
let me know.
Comment 4 Need Real Name 2003-03-21 15:32:04 EST
I have already tried 'redhat-config-xfree86' after installing via text mode.   
It crashes the system in the same manner as the installer...that's the 
problem...any attempt to bring up graphical mode crashes the system because 
Redhat installs what seems to be the wrong video driver.  It's a catch 
22...'redhat-config-xfree86' has to come up in graphical mode to configure, but 
it crashes the system, so you can't configure.

The are really two issues being discussed here:

(1)  Redhat misdetecting and using wrong video driver, so that the graphics 
system cannot be used.

(2)  How to configure the graphical system from text mode so it will work.

It is (1) that is the key issue of this bug report.  Redhat thinks it knows what 
the video hardware is, and attempts to use the wrong video driver on ANY attempt 
to initially bring up or configure the graphical system.  There does not seem to 
be any way to stop Redhat from initially using the video driver it selects, thus 
creating a "catch 22" situation.   THAT SEEMS TO ME TO BE A BUG.    At the very 
least, Redhat should give you an option to install a generic low-res graphic 
driver so you can get the graphics system running on the install, or later on 
'redhat-config-xfree86'.

On the question of (2), I was finally able last night, after many hours and 
several days, to successfully bring up the graphical system.  This required many 
complicated steps:

- find and download the correct RPM update files for Redhat 8 from the NVIDIA 
website
- install NVIDIA kernel updates and drivers in text mode on Redhat
- hand construct a custom XF86Config file to load the correct driver, free of 
ancillary errors

All steps were difficult, and the last step took many unsuccessful tries, as the 
correct values for the fields are not completely documented.  I had to merge a 
XF86Config from another PC, which was created by Redhat, and a XF86Config from 
Nvidia.

If there was an easier way to do this, I could not find it.   Without installing 
the kernel updates and video driver from Nvidia, I do not think that the 
graphics system could have been made to work (unless a low-res generic driver 
was available).

I do have a question for you on issue (2)...now that I have the graphics 
subsystem working, how can I configure Redhat to bring up the graphics system on 
boot-up?
Comment 5 Seth Bardash 2003-03-28 22:26:44 EST
Have same problem on an ASUS A7N266-VM/AA MB. RH 8.0 install CD crashes the 
system at the same point. It would be helpful to see the X86 config file that 
you got working. Also when RH 8.0 is installed in text mode and grub is 
selected it crashes the system on reboot - says file is too large to load.

Any help would be appreciated.
Comment 6 Seth Bardash 2003-03-29 21:01:38 EST
Have A7N266-VM/AA working!!!

Here are the problems:

1) RH 8.0 Install CD crashes in graphics install - Use "linux text" mode.
2) Grub does not work on the A7N266-VM/AA - Use lilo.
3) 2 sets of drivers required: get them at http://www.nvidia.com
   nForce chip set for LAN and audio (used rev 1.0-0248)
   nVidia unified graphics for X Windows
4) Rebuild src.tar.gz files for #3 for compatability with your kernel rev.
5) Up2date hangs and must be restarted to complete. 
   It also does not update the lilo.conf file.

Here is how to get it working:

Install RH 8.0 Linux in text mode only (Redhat 8.0 does not presently support 
nVidia nForce 220-D install in graphics mode – does not recognize chipset, LAN, 
graphics or audio properly). When you get to the X configuration screen -> 
select the "skip" option.

Install NVIDIA_nforce-1.0-0248.rh80up_2.4.18_14.athlon.rpm to get the LAN 
drivers working (needed so we could download the rest of the files to run 
up2date and the driver files). Then put the hostname into the /etc/hosts file 
and the /etc/sysconfig/network file:

>cat /etc/hosts
# Do not remove the following line, or various programs
# that require network functionality will fail.

127.0.0.1       linuxsvr        localhost.localdomain   localhost 
(Put system name here – linuxsvr)

>cat /etc/sysconfig/network
NETWORKING=yes
HOSTNAME=linuxsvr <-(Put system name here)

Run “setup” from a command line to start system text based setup command and 
use the network configuration option to set up the ethernet address, mask, 
gateway and DNS server address. You can also use the system configuration 
option on the main menu to turn off services you may not need – like iptable, 
ipchains, pcmcia, isdn, lpn and turn on services you may want – like nfs, smb 
(samba – NTFS file system), ipop3 (for email) and others……

Reboot the machine.

Configure up2date to be able to update the machine from Red hat’s secure update 
site. Then run "up2date -uv" from the command line. If it hangs during install 
reboot the machine and restart the update process. It will complete the second 
time around but does not update lilo.conf.

Once the machine is updated from Red hat, you may need to update 
the /etc/lilo.conf file. To do this, copy and paste the existing entry and just 
change the revision level on the vmlinuz and the initrd files to match the 
updated kernel (found in its install location of /boot). Also give the second 
entry a new name in the label line. 

Once you have updated lilo.conf run “lilo –v” from the command line. This will 
rewrite the master boot sector on the boot disk so that you can bring up the 
different kernels at boot time.

Reboot the machine and select the new kernel – by what name you gave it in the 
label= line above. Expect to see a few errors as the rpm you installed for the 
original kernel is not there anymore for the new kernel. Disregard them. Now 
unpack the source for file: NVIDIA_nforce-1.0-0248.src.rpm and follow the 
instructions: run “make” then “make install”. Then reboot choosing the new 
kernel. It should come up fine and allow you to access the LAN.

Next you need to build the graphics and GLX drivers for the built-in graphics 
adapter. They MUST be the same revision. We used NVIDIA_kernel-1.0-4191.tar.gz 
and NVIDIA_GLX-1.0-4191.tar.gz. You unpack these: tar xzvf filename.tar.gz and 
then do a make and a make install. You MUST do the kernel module first. You 
need to put an XF86Config file into the /etc/X11 directory. If you want to, 
modify the XF86Config file for your monitor – it is presently set to a generic 
1024x768 16 bit color depth. This works for almost all monitors. Next run 
mouseconfig and select the mouse type you are using.

Test it: run “ startx”. 

To get the machine to come up in graphics mode login at boot time edit 
the /etc/inittab file as follows:

Change the line that reads: id:3:initdefault: to id:5:initdefault: and save it.

Reboot. Now pick which window manager you want to run by default at the bottom 
of the window and then log in normally. If you are running KDE (we do) you can 
access all kinds of system configuration utilities from the menu on the bottom 
left icon.

Enjoy. Email me for the files that got this working.

Thanks to William Myre for the starting point I needed
to build the XF86Config file.

Seth Bardash 

seth@integratedsolutions.org
Comment 7 Seth Bardash 2003-03-29 21:13:48 EST
Correction to last post:

Line that read:

Now unpack the source for file: NVIDIA_nforce-1.0-0248.src.rpm and follow the 
instructions: run “make” then “make install”.

Should read:

Now unpack the source for file: NVIDIA_nforce-1.0-0248.src.tar.gz and follow 
the instructions: run “make” then “make install”.
Comment 8 Michael Fulbright 2003-04-02 15:32:46 EST
Mike doesn't RHL 9 have nforce support?
Comment 9 Mike A. Harris 2004-09-29 15:02:47 EDT
Nvidia's 'nforce' integrated chipsets have been supported in
XFree86 and X.Org for a while now, although they do not appear
to have been supported in XFree86 4.2.x which shipped in Red Hat
Linux 8.0.

If you experience problems with 'nforce' based video hardware
under the latest version of Fedora Core, please file a bug
report in the X.Org bugzilla located at http://bugs.freedesktop.org
in the "xorg" component for 'nv' driver developers to investigate.

Once you've filed your bug report to X.Org, if you paste the new
bug URL here, Red Hat will continue to track the issue in the
centralized X.Org bug tracker, and will review any bug fixes
that become available for consideration in future updates.

Setting status to "CURRENTRELEASE" as this hardware should now
be supported in Fedora Core 2.

Thanks.

Note You need to log in before you can comment on or make changes to this bug.