Bug 863033 - ip link set eth0 down on tg3 (BCM5701 - 3C996B-T) leads to BUG: soft lockup - CPU stuck
ip link set eth0 down on tg3 (BCM5701 - 3C996B-T) leads to BUG: soft lockup -...
Status: CLOSED DUPLICATE of bug 826718
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.3
All Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: John Feeney
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-04 05:39 EDT by Michal Žejdl
Modified: 2013-03-01 09:43 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-01 09:43:04 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg (4.62 KB, text/plain)
2012-10-04 05:39 EDT, Michal Žejdl
no flags Details

  None (edit)
Description Michal Žejdl 2012-10-04 05:39:06 EDT
Created attachment 621495 [details]
dmesg

Description of problem:
Shutdown of interface associated with tg3 driver makes kernel unusable. I tried two 3C996B-T in two different MoBos (both i686 and x86_64). Last 6.2 kernel is ok.

Version-Release number of selected component (if applicable):
all 6.3 kernels

How reproducible:
always

Steps to Reproduce:
1. insert 3C996B-T NIC
2. boot
3. ip link set ethx up
4. ip link set ethx down
  
Actual results:
Unusable kernel.

Expected results:
Normal interface shutdown.

Additional info:
Comment 2 John Feeney 2012-10-15 15:45:31 EDT
This was a known upstream problem and is fixed by the update of tg3 to
version 3.124. This update is on track for inclusion into RHEL6.4.

If you can test RHEL6.4, please add a comment to this bugzilla with your
findings. Thanks.
Comment 3 Michal Žejdl 2013-03-01 04:59:29 EST
Problem no longer exists - 2.6.32-358.0.1.el6.i686, tg3 3.124.
Thanks.
Comment 4 John Feeney 2013-03-01 09:43:04 EST
Thank you for the feedback. Much appreciated. 

I am closing this as a duplicate of bz826718.

*** This bug has been marked as a duplicate of bug 826718 ***

Note You need to log in before you can comment on or make changes to this bug.